Announcement

Collapse
No announcement yet.

Help - vortec 350 strange misfire

Collapse

Unconfigured Ad Widget

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help - vortec 350 strange misfire

    I've gone through alot of the threads on common vortec misfire problems, and it seems my problem is a little different. Trying to fix the truck for a buddy; '96 K2500 with about 150k miles.

    Here's the problem. Its gotten a progressively worse misfire, more than 2 cylinders it seems. Was misfiring only when cold before, but now does it all of the time. The curious thing, is that it does NOT set any misfire or other codes on the scanner. Here is the clue for anyone thats experienced this. The plugs on the drivers side, all of them, look wet as compared to those on the passenger's side. That's all the clues I can find.

    History on the truck; checked compression just tonight, was 179-185 PSI on all cylinders; just changed the crank, cam sensors; new distributor, new plugs, wires cap and rotor - spark is strong on all cylinders. Tried doing an injector cleaning with no help. Oil is clean; no antifreeze trail in the exhaust - just a rotten egg smell from unburned fuel.

    I'm thinking pressure regulator or multiple injector failures? Help! Thanks
    Last edited by 97sierra454; 12-08-2009, 07:58 PM.
    :fsg:
    1997 Sierra 2500HD 4x4, 454, ECSB
    1998 Silverado K1500 Z71, 350, ECSB
    2009 Pontiac G8 GT Sport

  • #2
    Re: Help - vortec 350 strange misfire

    check the temp sensor in the right cylinder head, or maybe the EGR valve..
    either one could cause your problems
    '95 Tahoe LT 4x4, TBI with Vortec crate motor.
    God created all men, and Sam Colt made them equal.

    Comment


    • #3
      Re: Help - vortec 350 strange misfire

      There isn't a temp sensor on the right cylinder head; there's the gauge sender on the left head, but that seems fine.

      I did check the EGR to see if its plugged open, and its fine. Go figure.

      I'm wondering if the FRP puked and its pouring gas into the left cylinder bank????
      :fsg:
      1997 Sierra 2500HD 4x4, 454, ECSB
      1998 Silverado K1500 Z71, 350, ECSB
      2009 Pontiac G8 GT Sport

      Comment


      • #4
        Re: Help - vortec 350 strange misfire

        You didn't say whether you had measured fuel pressure - test if the pressure is correct and/or whether it bleeds down after the pump turns off. The rotten egg smell - sure the converter on that bank isn't plugged, and causing it to struggle to run? Couple other thoughts - will your scanner measure the engine temp that the computer sees? Could be an issue with the temp sensor in the t-stat housing, especially with a cold engine. Does the motor run worse at idle and smooth out with throttle opening? Air filter plugged? Worn distributor gear?
        Last edited by 521dvx; 12-09-2009, 11:04 AM.

        Comment


        • #5
          Re: Help - vortec 350 strange misfire

          Update, I'm about at my wits end with this thing. I got the MFI upgrade kit, and when I got the intake opened up, it looked like the driver's side of the intake was washed with raw fuel - figured I'd solved my problem that the pressure regulator or an injector puked and were leaking inside the plenum. Well, I got the MPI kit installed and it still runs exactly the same!!!!!

          Still does not set any codes, still seems to be misfiring primarily on cyls 3 and 5. Those plugs come out wet with like raw gas. Pull the plug out and check for spark, and they both spark good. If they are sparking at the right time, I have no idea. Still no codes. Even tried an extra computer i have and it made no difference.

          Coolant temp sensor is fine (checked with scanner), and engine skips at all RPM's. Backfires under heavy load if you try to get into it, and it doesn't clear out at higher rpm's. Still doesn't show any misfires on the ECM for some reason. Checked the fuel pressure and that seems fine as well; also put in a new fuel filter. Help!!!!
          :fsg:
          1997 Sierra 2500HD 4x4, 454, ECSB
          1998 Silverado K1500 Z71, 350, ECSB
          2009 Pontiac G8 GT Sport

          Comment


          • #6
            Re: Help - vortec 350 strange misfire

            Oh, and I also tested the radiator with a pressure tester and it holds pressure fine, so I don't think there are head gasket or intake gasket problems either. Also checked the firing order several times.
            :fsg:
            1997 Sierra 2500HD 4x4, 454, ECSB
            1998 Silverado K1500 Z71, 350, ECSB
            2009 Pontiac G8 GT Sport

            Comment


            • #7
              Re: Help - vortec 350 strange misfire

              mmmmm, good one. my only guess would be a burnt vavle, have you tried a leak down test?

              1997 K1500 Built vortec 355
              transbuilderguy built 4L65E, yank, 14 bolt

              Comment


              • #8
                Re: Help - vortec 350 strange misfire

                That's about the only thing I haven't done at this point.... but then again, I would think that if I had a valve problem, it wouldn't have had such a good compression test result.
                :fsg:
                1997 Sierra 2500HD 4x4, 454, ECSB
                1998 Silverado K1500 Z71, 350, ECSB
                2009 Pontiac G8 GT Sport

                Comment


                • #9
                  Re: Help - vortec 350 strange misfire

                  well, in a nutshell its possible. try a leak down test on every cylinder

                  1997 K1500 Built vortec 355
                  transbuilderguy built 4L65E, yank, 14 bolt

                  Comment


                  • #10
                    Re: Help - vortec 350 strange misfire

                    O2 sensor or catalytic converter on that bank?

                    2005 2500HD>Duramax>EFI Live DSP5 by Punisher Performance>FASS Platinum LP>AFE Turbo MP>EGR Blocked>PCV Rerouted>Mild audio setup>4" Exhaust>Alligator Performance Race Fuel Valve>Edge Insight CTS

                    Comment


                    • #11
                      Re: Help - vortec 350 strange misfire

                      naa, tha would cause all 4 cylinders to be fuel soaked, not just 2

                      1997 K1500 Built vortec 355
                      transbuilderguy built 4L65E, yank, 14 bolt

                      Comment


                      • #12
                        Re: Help - vortec 350 strange misfire

                        Originally posted by james_8997 View Post
                        naa, tha would cause all 4 cylinders to be fuel soaked, not just 2
                        Oh I guess I mis read. Thought he said the whole side was misfiring

                        2005 2500HD>Duramax>EFI Live DSP5 by Punisher Performance>FASS Platinum LP>AFE Turbo MP>EGR Blocked>PCV Rerouted>Mild audio setup>4" Exhaust>Alligator Performance Race Fuel Valve>Edge Insight CTS

                        Comment


                        • #13
                          Re: Help - vortec 350 strange misfire

                          i would go with bad injectors...fuel comes from injectors to the cylinder...i would pressure test the FRP for a bleeding injector...
                          sigpic'68 CAMERO SS 396CI FULLY RESTO, TO MANY MODS, 468HP
                          '64 JETSTAR 350ROCKET. COMP CAM, EDELBROCK INTAKE, MSD, 388HP
                          '94 TRK, 350CI,DETROIT LOCKER, MSD, COMP CAM, EDELBROCK INTAKE,FLOWMASTER, CIA

                          Comment


                          • #14
                            Re: Help - vortec 350 strange misfire

                            Originally posted by childsplay View Post
                            i would go with bad injectors...fuel comes from injectors to the cylinder...i would pressure test the FRP for a bleeding injector...
                            He just said he replaced all the injectors with the updated MPI.
                            Did the new injector pod come with a FPR?

                            Comment


                            • #15
                              Re: Help - vortec 350 strange misfire

                              umm...Regulator Faulty Regulator/Weak Spring Causing a Rich Fuel Mixture. 2.Faulty or Disconnected MAP Sensor Causing a Rich Fuel Mixture.
                              sigpic'68 CAMERO SS 396CI FULLY RESTO, TO MANY MODS, 468HP
                              '64 JETSTAR 350ROCKET. COMP CAM, EDELBROCK INTAKE, MSD, 388HP
                              '94 TRK, 350CI,DETROIT LOCKER, MSD, COMP CAM, EDELBROCK INTAKE,FLOWMASTER, CIA

                              Comment

                              Working...
                              X