GM Inside - Ford Inside - Ford Ranger - Jeep - American Muscle

Support FSC and see no ads! - Click Here
Page 1 of 3 123 LastLast
Results 1 to 20 of 50

subwoofer amp turns on on start up then shuts off

This is a discussion on subwoofer amp turns on on start up then shuts off within the Audio/Video Electronics forums, part of the General Discussion category; got a 1200 watt sony explode amp powering 2 12" subs. my problem is that when i turn the truck ...

  1. #1
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    subwoofer amp turns on on start up then shuts off


    Support FSC and see no ads! - Click Here
    got a 1200 watt sony explode amp powering 2 12" subs. my problem is that when i turn the truck on the blue light on the sub indicating it has power will turn on for a good second or 2 then shutoff. this is 2nd 2 channel i've had to buy and im starting to get tired of wasting my money. help please??


    and also i went to best buy, where it was all installed, and too auto zone and they both said i have a power drain when the truck is off. when it was originally wired only one remote wire was used for both amps but i changed that today to two remotes.

    thanks alex

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

  2. #2
    ......................... Atomic's Avatar
    Join Date
    Jun 2005
    Location
    AL
    Age
    25
    Posts
    6,286

    Re: subwoofer amp turns on on start up then shuts off

    Where is your remote wire coming from?

  3. #3
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    Re: subwoofer amp turns on on start up then shuts off

    the headunit

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

  4. #4
    ......................... Atomic's Avatar
    Join Date
    Jun 2005
    Location
    AL
    Age
    25
    Posts
    6,286

    Re: subwoofer amp turns on on start up then shuts off

    and where is the accessory power to the head unit coming from?
    Last edited by Atomic; 06-29-2009 at 02:18 PM.

  5. #5
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    Re: subwoofer amp turns on on start up then shuts off

    umm which wire is that? lol

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

  6. #6
    ......................... Atomic's Avatar
    Join Date
    Jun 2005
    Location
    AL
    Age
    25
    Posts
    6,286

    Re: subwoofer amp turns on on start up then shuts off

    the red one usually

    what im getting at is if your headunit accessory is connected to a constant power, then your headunit stays on, which means your amp stays on. But this doesnt sound like the problem at all. It sounds more like you either have the amp hooked up wrong so the impedence is too low (wired for 1 ohm or something), or there are some blown fuses in the amp.

    If you had power drain when the truck is off you would have a dead battery every day.

  7. #7
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    Re: subwoofer amp turns on on start up then shuts off

    theres 2 40 fuses on teh outside of the amp, they're both fine, the one on the power wire is fine. my power and ground wires are both 6 guage. could that be the problem?

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

  8. #8
    ......................... Atomic's Avatar
    Join Date
    Jun 2005
    Location
    AL
    Age
    25
    Posts
    6,286

    Re: subwoofer amp turns on on start up then shuts off

    6 is a little small, i would do at least 4, but I dont think thats the problem.

    If you disconnect the speaker from the amp and just turn the amp on, does it still do it?

  9. #9
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    Re: subwoofer amp turns on on start up then shuts off

    well i got a 2 channel runnin the subs and a 4 channel runnin the speakers (dont ask me why its this way my brother did this back when he drove it)

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

  10. #10
    ......................... Atomic's Avatar
    Join Date
    Jun 2005
    Location
    AL
    Age
    25
    Posts
    6,286

    Re: subwoofer amp turns on on start up then shuts off

    ....thats fine, but still doesnt answer my question above

  11. #11
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    Re: subwoofer amp turns on on start up then shuts off

    sorry which amp and which speakers>?

    i cant even get the 2 channel to come on now.

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

  12. #12
    Why leave it stock? Polecat's Avatar
    Join Date
    Oct 2001
    Location
    Stillwater, Ok
    Age
    47
    Posts
    1,834

    Re: subwoofer amp turns on on start up then shuts off

    do you have voltage to the amp?
    If so, dis-connect the speakers, see if it stays on. This will eliminate blown woofer, or wired incorrectly. Just isolating if the amp comes on, and will stay on, without a load.

  13. #13
    giggidy
    Join Date
    Jun 2004
    Location
    Spartanburg, SC
    Age
    33
    Posts
    942

    Re: subwoofer amp turns on on start up then shuts off

    Agreeing with Polecat, a shorting speaker or speaker wire can and will make the amp shut off as it is. However, if it won't turn on at all now AND it was draining the battery, you could have a bad transistor on the power supply. That would cause both problems.

  14. #14
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    Re: subwoofer amp turns on on start up then shuts off

    i disconnected the power cord that runs to the 4 channel and then the 2 channel wouldnt even turn on.
    im pretty sure its blown.

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

  15. #15
    giggidy
    Join Date
    Jun 2004
    Location
    Spartanburg, SC
    Age
    33
    Posts
    942

    Re: subwoofer amp turns on on start up then shuts off

    Just to make sure, did you disconnect power directly at the amp, or before a distribution block, or where?

  16. #16
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    Re: subwoofer amp turns on on start up then shuts off

    unplugged it at the amp, turned the iginition, nothin so i disconnected it from the battery and still, nothin.

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

  17. #17
    giggidy
    Join Date
    Jun 2004
    Location
    Spartanburg, SC
    Age
    33
    Posts
    942

    Re: subwoofer amp turns on on start up then shuts off

    Quote Originally Posted by 01SilvyZ71 View Post
    unplugged it at the amp, turned the iginition, nothin so i disconnected it from the battery and still, nothin.
    Normally I'd say crack it open and see what's dead, may be easily fixable. However, if you do open it up, you may become depressed or angry when you see what's inside. So I'll just stick with its probably new amp time LOL

  18. #18
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    Re: subwoofer amp turns on on start up then shuts off

    Quote Originally Posted by ibanender View Post
    Normally I'd say crack it open and see what's dead, may be easily fixable. However, if you do open it up, you may become depressed or angry when you see what's inside. So I'll just stick with its probably new amp time LOL
    damn, this truck has had 2 2 channels and 3 4 channels.
    this **** is gettin old. im thinkin ill just take out the subs, the box and just sell em cause i mainly listen to country anyways lol
    Last edited by CarolinaHD; 07-02-2009 at 09:55 PM.

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

  19. #19
    giggidy
    Join Date
    Jun 2004
    Location
    Spartanburg, SC
    Age
    33
    Posts
    942

    Re: subwoofer amp turns on on start up then shuts off

    Quote Originally Posted by 01SilvyZ71 View Post
    damn, this truck has had 2 2 channels and 3 4 channels.
    this **** is gettin old. im thinkin ill just take out the subs, the box and just sell em cause i mainly listen to country anyways lol
    If you're going through equipment like that, I think you need to look at your installation and what you're putting in there. If you keep putting crap in there, expect it to die. If something is wrong with your installation, expect it to die.

  20. #20
    EFI Live
    Join Date
    Jan 2008
    Location
    Wolfpack Country
    Posts
    10,294

    Re: subwoofer amp turns on on start up then shuts off

    well the first 2 channel my brother touched the power to the ground (like a year ago) so i replaced it finally with the sony xplode back in may and we used to have a jl 4 channel but we got it used and it was old anyways so i replaced it with somethin i cant remember lol.

    all the stuff has been installed at best buy minus the first 2 channel amp

    Thanks to:
    Dustin @ Diesel Addiction
    Rick @ Pro Fab Performance
    John @ Kennedy Diesel

 

 
Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •