***Login to the Forum here ***

Support FSC and see no ads! - Click Here
Results 1 to 17 of 17

4L80E Won't Shift into OD

This is a discussion on 4L80E Won't Shift into OD within the Technical / Maintenance forums, part of the General Discussion category; I was out driving my 94 fullsize today and the 4L80E wouldn't shift into OD, any idea what the problem ...

  1. #1
    Ding Fries Are Done!
    Join Date
    Oct 2003
    Location
    Over there
    Age
    31
    Posts
    372

    4L80E Won't Shift into OD


    Support FSC and see no ads! - Click Here
    I was out driving my 94 fullsize today and the 4L80E wouldn't shift into OD, any idea what the problem could be? TPS maybe?

  2. #2
    Registered User chrisk1500's Avatar
    Join Date
    Jun 2005
    Location
    Canada
    Posts
    612

    Re: 4L80E Won't Shift into OD

    Not sure about the gassers, but on the diesels the 4L80E won't shift into OD if the coolant temp sensor is shot...
    07.5 LMM DMAX 2500 HD, ext cab, 4x4

  3. #3
    Ding Fries Are Done!
    Join Date
    Oct 2003
    Location
    Over there
    Age
    31
    Posts
    372

    Re: 4L80E Won't Shift into OD

    the temp sensor on the engine????

  4. #4
    Ding Fries Are Done!
    Join Date
    Oct 2003
    Location
    Over there
    Age
    31
    Posts
    372

    Re: 4L80E Won't Shift into OD

    What about the VSS? I checked it with a meter and it's not putting out any voltage (Hayne's book said it should put out 1/2 volt) and my speedo also isn't working.

  5. #5
    ASE/GM Cert. Technician
    Join Date
    Aug 2006
    Location
    Pembroke, NH
    Posts
    103

    Re: 4L80E Won't Shift into OD

    If the vss isn't working, the computer doesn't know whn to electonically shift into OD. the first 3 gears work off the old Hydra-matic and then the TCC and OD works off the ECM. Change your VSS and check your temp sensor too. Some truck have 2 sensors, 1 for the gauge and 1 for the ECM.

  6. #6
    Ding Fries Are Done!
    Join Date
    Oct 2003
    Location
    Over there
    Age
    31
    Posts
    372

    Re: 4L80E Won't Shift into OD

    where are the temp sensors located at?

  7. #7
    0_o o_0 0_o o_0 98GreenMachine's Avatar
    Join Date
    Aug 2005
    Location
    St. Paul, MN
    Age
    30
    Posts
    5,583

    Re: 4L80E Won't Shift into OD

    Quote Originally Posted by tucks20s
    where are the temp sensors located at?
    what year 350 do you have? There is one right in the front of the engine, just below the thermostat..
    08 HHR LS - 2.2 | 5 speed | 30 MPG

    98 K1500 Z71 - 204k | L31 | 60E | 3.73's | 3" BL | 33x12.5x15 Dick Cepek F-C II's | Dynomax Ultra Flo X DI/DO | 14 MPG

    84 S15 Jimmy 2dr 4x4 - engine/tranny all rebuilt

  8. #8
    Registered User Escadually's Avatar
    Join Date
    Dec 2006
    Location
    TN
    Posts
    52

    Re: 4L80E Won't Shift into OD

    ....and the other one should be down on the drivers side of the block in a water jacket.
    97 C3500 CC 7.4 Vortec Auto
    Pearl White/Candy Red
    Bagged,Cowl Hood, Escy front end, more to come...

    04 Dodge 3500 QC SRW Laramie
    Cummins Diesel, Auto
    BDPP stacked w/Edge EZ, 2* timing, Donaldson muffler, BD RFI w/CAI mod

  9. #9
    Ding Fries Are Done!
    Join Date
    Oct 2003
    Location
    Over there
    Age
    31
    Posts
    372

    Re: 4L80E Won't Shift into OD

    ok thanks guys.

    Which one controls the temp gauge on the cluster?

    Also which VSS should I replace since the 4L80E has two of them, the rear one?

    BTW it's a 94 model engine.

  10. #10
    0_o o_0 0_o o_0 98GreenMachine's Avatar
    Join Date
    Aug 2005
    Location
    St. Paul, MN
    Age
    30
    Posts
    5,583

    Re: 4L80E Won't Shift into OD

    Quote Originally Posted by tucks20s
    ok thanks guys.

    Which one controls the temp gauge on the cluster?

    Also which VSS should I replace since the 4L80E has two of them, the rear one?

    BTW it's a 94 model engine.
    hmmm..well somebody correct me if im wrong, but a 94 only had 1 temp sensor right?

    my dads 94 4.3 just had the one on top of the intake, just to the left of the thermostat housing..
    Last edited by 98GreenMachine; 12-16-2006 at 10:50 AM.
    08 HHR LS - 2.2 | 5 speed | 30 MPG

    98 K1500 Z71 - 204k | L31 | 60E | 3.73's | 3" BL | 33x12.5x15 Dick Cepek F-C II's | Dynomax Ultra Flo X DI/DO | 14 MPG

    84 S15 Jimmy 2dr 4x4 - engine/tranny all rebuilt

  11. #11
    Ding Fries Are Done!
    Join Date
    Oct 2003
    Location
    Over there
    Age
    31
    Posts
    372

    Re: 4L80E Won't Shift into OD

    Mine has the one to the left of the intake and the one on the d.s. head. I THINK my 4.3 was the same, but I'm not forsure.

  12. #12
    Ding Fries Are Done!
    Join Date
    Oct 2003
    Location
    Over there
    Age
    31
    Posts
    372

    Re: 4L80E Won't Shift into OD

    oh yea I just got the truck down off of the lift after testing both VSS's and the one in the back isn't working. Now I get to play the waiting game since no one around here carries anything for a 4L80E and it's the weekend

  13. #13
    ASE/GM Cert. Technician
    Join Date
    Aug 2006
    Location
    Pembroke, NH
    Posts
    103

    Re: 4L80E Won't Shift into OD

    The temp sensor on the intake is the one you want to change I believe. To make sure, unplug the one on the head and use a test light, hook it upto the battery positive post and have someone in the cab watching the gauge, and put 12v power to the 2 prongs, one at a time. If it's the correct plug, the gauge will spike instantly to hot. If it doesn't, then you have the wrong temp sensor and check the other one out the same way.
    Last edited by CustoMizedChevy; 12-16-2006 at 09:09 PM.

  14. #14
    rollin the nasty D's!!! Double Dueces's Avatar
    Join Date
    Apr 2006
    Location
    Minnesota
    Posts
    860

    Re: 4L80E Won't Shift into OD

    Quote Originally Posted by tucks20s
    ok thanks guys.

    Which one controls the temp gauge on the cluster?

    Also which VSS should I replace since the 4L80E has two of them, the rear one?

    BTW it's a 94 model engine.
    replace both, if it still does it then your ineed of a rebuilt tranny,

    I bought my truck with a bad tranny. I would start out in 1st gear then when about to go into 2nd gear it owuld skip it and hit up 3rd then 4th gear. The tranny shop was it was the 1-2 band then said that the 3-4 band was going out too and said tey would rebuild it for a $$$$ of change. So I looked around and got a rebuilt one for a deal then its been like a new truck ever since it! After 100K on the tranny it then goes to hell is what all GM fans told me about the tranny, they were shocked that it got 150K out of it though!!!

    '01 XCSB a few mods done to it.
    truck parts http://www.supermotors.net/vehicles/...ry/10422/66312

  15. #15
    Registered User
    Join Date
    Mar 2006
    Location
    StL, MO
    Posts
    426

    Re: 4L80E Won't Shift into OD

    Engine Coolant Temp sensor (input to ECM) is located on intake manifold. Coolant Temp Sending Unit (to guage) is in the left head.

    Is your Check Engine light on? Should be, if VSS is shot. Start by replacing the suspected faulty VSS.
    1991 K1500 - 'Red'
    350 Roller Cam TBI, 5-speed manual

    1995 Chevrolet Caprice 9C1 LT1
    Former Arkansas State Police

  16. #16
    Ding Fries Are Done!
    Join Date
    Oct 2003
    Location
    Over there
    Age
    31
    Posts
    372

    Re: 4L80E Won't Shift into OD

    no the check engine light is not on, but I did a check on the VSS and it is not working.

    I ordered a VSS and it will be in today so I'll see if that is the problem...

    The tranny has around 20,000 miles on it so I don't think it needs to be rebuilt.

    I'll go ahead and pick up a temp sensor incase that is messed up as well.

  17. #17
    Ding Fries Are Done!
    Join Date
    Oct 2003
    Location
    Over there
    Age
    31
    Posts
    372

    Re: 4L80E Won't Shift into OD

    I checked the temp sensor and it's fine.

    I installed the new VSS and the speedo now works, but when I got out and drove the truck it shifted into OD, but wouldn't downshift so now it's stuck in OD. Any suggestions?

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •