If you are not able to login to the forum, please Contact Us here to let us know. Thanks!

Support FSC and see no ads! - Click Here
Results 1 to 2 of 2

Problems with MAF sensor on 98 chevy c1500 2wd 5.7 Vortec

This is a discussion on Problems with MAF sensor on 98 chevy c1500 2wd 5.7 Vortec within the Technical / Maintenance forums, part of the General Discussion category; Problems with MAF sensor on 98 chevy c1500 2wd 5.7 Vortec -------------------------------------------------------------------------------- I was on my way to work this ...

  1. #1
    Registered User
    Join Date
    May 2007
    Location
    Las Vegas
    Posts
    2

    Angry Problems with MAF sensor on 98 chevy c1500 2wd 5.7 Vortec


    Support FSC and see no ads! - Click Here
    Problems with MAF sensor on 98 chevy c1500 2wd 5.7 Vortec

    --------------------------------------------------------------------------------

    I was on my way to work this morning in my trusty 98 silverado w/185k miles, (still running strong as ever), when all of the sudden I stepped on the gas, and just before half throttle the motor started to choke. Quickly I headed back home to diagnose the issue. I ran a CPU check and came up with the error code P0102, which means that the MAS, or possibly, the MAP sensor are in need of replacement. So I replace them both....and still...no luck. the truck idles perfectly and up to about 1/2 throttle runs very well. Currently I have the battery unplugged and am hoping this will drain the aux. power and reset the computer codes. Will this work, or do I have to reset the codes with a programmer, the "stealership" wants $100 just to do this and I have already spent enough money today. Any help is much appreciated....HELP!!!!!!!! No truck, no work... no work, no $$$$

  2. #2
    Registered User Sharky's Avatar
    Join Date
    May 2007
    Location
    The Netherlands, Europe
    Posts
    9

    Re: Problems with MAF sensor on 98 chevy c1500 2wd 5.7 Vortec

    I do have a similar problem with my '96 5.7 vortec...
    AND...it worsened after a few weeks! It started just like your problem, but now I can't even drive it out of the street, because it's just choking/stalling and than dies out.
    I did change the MAP sensor since I measured some strange voltvallues there, but it didn't help. I have not replaced the MAF yet, because I don't really know for sure if this is the cause of the problem. I do not have a SES warning btw. I got fuel pressure. Even when engine is choking.

    '96 Red 5.7L Vortec 2WD C1500
    '80 Blue 5.7L Corvette

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •