If you are not able to login to the forum, please Contact Us here to let us know. Thanks!

Support FSC and see no ads! - Click Here
Results 1 to 20 of 20

shake on acceleration

This is a discussion on shake on acceleration within the Technical / Maintenance forums, part of the General Discussion category; I have a 97 Tahoe 4wd and I noticed my truck started shaking when I accelerate. I went to have ...

  1. #1
    Registered User
    Join Date
    Feb 2004
    Location
    Dallas, TX
    Age
    29
    Posts
    29

    Exclamation shake on acceleration


    Support FSC and see no ads! - Click Here
    I have a 97 Tahoe 4wd and I noticed my truck started shaking when I accelerate. I went to have the tires balanced and rotated but this didn't help at all. The shake is only when I accelerate but the transmission shifts fine still. The shaking gets really bad at about 65-70 when pressing on the gas. Any suggestions?

  2. #2
    Registered User
    Join Date
    Oct 2005
    Location
    Texas
    Age
    65
    Posts
    157

    Re: shake on acceleration

    does the vibe go away after you have reached driving speed...if it does, then I vote Transmission/Tcase mount...sometimes hard to tell just by looking at it as it can be cracked,etc and you just can't see it. Cheap, easy and very common.

  3. #3
    Curt 1992 chevy 5.7l
    Join Date
    Aug 2006
    Location
    tennessee
    Age
    29
    Posts
    1,143

    Re: shake on acceleration

    check drive shaft.....may be u joints going...
    92 5.9l full roller,fully forged,scatt crank.AFR 190cc heads,Crane 2032cam,nv3500,S2 6 Puck clutch.Hurst Short Shifter,14-bolt,auburn 4.11.Carbed

  4. #4
    MX 4 LIFE 951500z71's Avatar
    Join Date
    Oct 2007
    Location
    Michigan
    Age
    23
    Posts
    144

    Re: shake on acceleration

    now this sounds weird.. but my truck did the same exact thing and my #1 cylinder spark plug wire was melted.. my brackets are missing and it was laying behind the manifold.. zip tied them up and now its running good again.. mine ran fine coasting also but on the gas at a steady speed it shook like that i thought it was tranny problems until i seen it arcing..

  5. #5
    Registered User
    Join Date
    Feb 2004
    Location
    Dallas, TX
    Age
    29
    Posts
    29

    Re: shake on acceleration

    I checked everything out. I even checked my spark plugs. Too bad that wasn't it. I looked under at the u joints and I may just not know that they are going but they looked ok. I drove around again really trying to pay attention to what it was. What happens is while accelerating up to 30 the shake is moderate. Once I hit 30 I am ok as long as I don't accelerate above 1500 rpms. once I hit 1500 it starts shaking. As soon as I let off it goes away; hit the gas again up to 1500 and its back. From what I have read on here I guess this means I have a crack in the transfer case or transmission mount? Finally if it is this I am guessing I just have to replace it or is there some complicated method?

  6. #6
    Registered User Mn02Sierra's Avatar
    Join Date
    Oct 2002
    Location
    Minnesota
    Posts
    1,170

    Re: shake on acceleration

    Sounds like U-Joints to me

  7. #7
    Registered User
    Join Date
    Feb 2004
    Location
    Dallas, TX
    Age
    29
    Posts
    29

    Re: shake on acceleration

    I looked over the U Joints again and I really can't tell there is anything wrong. Maybe it is all internal. Here is a question, could this in anyway be caused by not receiving enough gas via the gas pump?

  8. #8
    Registered User
    Join Date
    Oct 2005
    Location
    Texas
    Age
    65
    Posts
    157

    Re: shake on acceleration

    Where in Dallas? I'm in McKinney.

  9. #9
    Registered User
    Join Date
    Apr 2007
    Location
    indiana
    Posts
    832

    Re: shake on acceleration

    You can't tell about U Joints just by looking at them. Pull the shaft and move them thru their travel,see how they feel. RW

  10. #10
    The Flying Dutchman neevnav's Avatar
    Join Date
    Jan 2007
    Location
    Stouffville, Ontario, Canada
    Age
    30
    Posts
    1,436

    Re: shake on acceleration

    I agree on u-joints. Turn the shaft with the truck in park and see if it has any play.


    1994 K1500 350
    K&N Open Element, MSD 6A, Cobalt SS E-fans, BFG A/Ts, Cat-back duals, TSX HID retrofit

    Quote Originally Posted by Jim
    I'm out of state withno Internet. I had to fix the forum with my iPhone. Sorry guys

  11. #11
    406cu.in. of fun
    Join Date
    May 2006
    Location
    Tacoma, WA
    Posts
    475

    Re: shake on acceleration

    I feel your pain man. I have the same problem with my 99 4x4 crew. I've changed the plugs and wires even though they all looked good. I also removed both driveshafts and took them to a company that balances them and inspects them. After a $140 bill, that didn't do anything either. Right now, I'm just living with it.
    '91 C1500 with a 406 AFR Heads, Compcams 12-423-8 retro-roller camshaft, Thorley headers, Holley 770 carb, Edelbrock Air Gap manifold, K&N X-Stream, and quickly balding rear tires

    '08 K2500HD LTZ "Southern Comfort" crew cab, Duramax, 6" lift, 35" tires with Procomp wheels, EFILive

  12. #12
    Registered User
    Join Date
    Apr 2007
    Location
    indiana
    Posts
    832

    Re: shake on acceleration

    Are any of these units lifted? Drive shaft angle can cause vibrations such as this. RW

  13. #13
    406cu.in. of fun
    Join Date
    May 2006
    Location
    Tacoma, WA
    Posts
    475

    Re: shake on acceleration

    Mine is, but the angles are all well within spec because of the angled lift blocks.
    '91 C1500 with a 406 AFR Heads, Compcams 12-423-8 retro-roller camshaft, Thorley headers, Holley 770 carb, Edelbrock Air Gap manifold, K&N X-Stream, and quickly balding rear tires

    '08 K2500HD LTZ "Southern Comfort" crew cab, Duramax, 6" lift, 35" tires with Procomp wheels, EFILive

  14. #14
    Registered User MacChev's Avatar
    Join Date
    Apr 2005
    Location
    GA
    Posts
    112

    Re: shake on acceleration

    Kik, see my post about fuel pump; yours is probably U joint as they are saying, but mine also vibrated some while accelerating, and it is the fuel pump. Probably a different vibration than what you have though.

  15. #15
    Registered User
    Join Date
    Feb 2004
    Location
    Dallas, TX
    Age
    29
    Posts
    29

    Re: shake on acceleration

    I am gonna change out the rear u joints tomorrow. Hopefully this fixes it. I'll let y'all know

    I think I have a problem with the fuel pump too but not as bad as not starting. It starts most of the time, just makes funny noises.

    I'm in South Dallas, basically in Duncanville/Cedar Hill. I go to school up here near by.

  16. #16
    Registered User hyeride00's Avatar
    Join Date
    May 2004
    Location
    Orange County, Ca
    Posts
    26

    Re: shake on acceleration

    I am having a similar problem that just started tonight. Yesterday i replaced the drivers side header gasket, changed the oil, and the front brakes. Todat after driving on the freeway at about 85, it started to shake on acceleration from the stop lights. If i accelerate slowly, it seems ok. But when i get on it and hear the radix start to whine, it shakes and even pings a little. This is at about 2000-2500 rpm. I went to the store and it finally threw an SES light on, so i am hoping auto tap will tell me what is going on. Oh, i also got a re-tune from nelson....dont know what all of the sudden could have caused it.

    Matt
    2000 Silvo ECSB 6.0 4L80E radix

  17. #17
    Registered User
    Join Date
    Feb 2004
    Location
    Dallas, TX
    Age
    29
    Posts
    29

    Re: shake on acceleration

    Fixed. U joints it was.
    Last edited by kiksomepoo; 11-19-2007 at 11:18 PM.

  18. #18
    HittingBadPitchesSince82 atenisplyr's Avatar
    Join Date
    Feb 2007
    Location
    The Republic of Texas
    Age
    32
    Posts
    600

    Re: shake on acceleration

    I'm having this problem too. I replaced my U-Joints a while back ago. My problem only happens when the motor is warming up. After driving it for about 3-5 minutes, it goes away and never happens again. Any ideas?
    '97 GMC ECSB GMT400
    Andrew

  19. #19
    Registered User
    Join Date
    Apr 2007
    Location
    indiana
    Posts
    832

    Re: shake on acceleration

    Any time I hear symptoms like this I think of coolant in a cyl. RW

  20. #20
    HittingBadPitchesSince82 atenisplyr's Avatar
    Join Date
    Feb 2007
    Location
    The Republic of Texas
    Age
    32
    Posts
    600

    Re: shake on acceleration

    Quote Originally Posted by retired wrench
    Any time I hear symptoms like this I think of coolant in a cyl. RW
    Really? Think it might be a bad head gasket? Hmmm...Sounds like a good excuse to get E-Tec 170's. What makes you think so?
    '97 GMC ECSB GMT400
    Andrew

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •