***Login to the Forum here ***

Support FSC and see no ads! - Click Here
Results 1 to 10 of 10

2003 Silverado Instrument Cluster Died

This is a discussion on 2003 Silverado Instrument Cluster Died within the Technical / Maintenance forums, part of the General Discussion category; I have a 2003 2500HD 6.0, I drove the truck home and everything was fine. Two hours later I start ...

  1. #1
    Registered User
    Join Date
    Dec 2006
    Location
    Canada
    Posts
    24

    2003 Silverado Instrument Cluster Died


    Support FSC and see no ads! - Click Here
    I have a 2003 2500HD 6.0, I drove the truck home and everything was fine. Two hours later I start it up and the gauges are dead (speedo, volts, temp, oil, water, tach and tranny temp), the gear selector and odometer are also dead as well as the 4wd indicator. The dash lights work as well as the blinkers.

    Which fuses and where are the grounds that I should check before replacing the panel?

    Thanks in advance,
    Roach

  2. #2
    Registered User
    Join Date
    Dec 2006
    Location
    Canada
    Posts
    24

    Re: 2003 Silverado Instrument Cluster Died

    Update. Driving to work this morning everything started working again, is this a loose ground?

  3. #3
    Registered User
    Join Date
    Mar 2008
    Location
    Indiana
    Age
    25
    Posts
    34

    Re: 2003 Silverado Instrument Cluster Died

    The plug connected at the back of the cluster may have gotten loose. All you have to do is pop the bezel off and remove the four screws holding it in. Just pop the plug out and firmly re insert it (It is a tight fit).

    If they all died and then came back to life, that is most likely your problem.

    If your too lazy for that, maybe it was a one time deal. ;)
    If it happens again, try pushing the cluster towards the dash and see if it flickers/starts working again.

  4. #4
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    47
    Posts
    20,465

    Re: 2003 Silverado Instrument Cluster Died

    my guess it will happen again. gm has a recall or tsb on the clusters going out. IF out of warranty get a upgraded cluster for an escalade.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


  5. #5
    Big Jake BigJake's Avatar
    Join Date
    Sep 2006
    Location
    louisiana
    Posts
    84

    Re: 2003 Silverado Instrument Cluster Died

    Just had mine in my 04 changed a few weeks ago. Dealership replaced under recall. They did ask me how many miles on the truck first. Something about over 70k and they would not cover it.
    2004 2500 ccsb 6.0, Superchips, 265/75/16 Toyo A/T's.

  6. #6
    Registered User
    Join Date
    Dec 2006
    Location
    Canada
    Posts
    24

    Re: 2003 Silverado Instrument Cluster Died

    Thanks for the replies.

  7. #7
    Registered User
    Join Date
    Mar 2008
    Location
    wisconsin
    Posts
    721

    Re: 2003 Silverado Instrument Cluster Died

    i got the letter in the mail...i think its 70 and below they cover it free...and up to 85k you pay for labor..anything after that your sol and the wallet takes the bullet
    2004 1500 5.3 standard cab long box Z85

    Stupidity is the number one sin

  8. #8
    Registered User
    Join Date
    Dec 2006
    Location
    Canada
    Posts
    24

    Re: 2003 Silverado Instrument Cluster Died

    GM is replacing mine for free Thursday morning even though it has 130000 kms on it. Thanks for the help.

  9. #9
    Registered User
    Join Date
    Oct 2005
    Location
    Lakeland, Fla
    Posts
    11

    Re: 2003 Silverado Instrument Cluster Died

    Well, I may have been bitten by the infamous cluster failure also. Went out to roll the windows up on my 2003 6L 2500HD and noticed that there were two lights on on the cluster down by where the shift indicator and odometer are. They looked like little blocks stacked in a staggered pattern one on each side of the odometer space. I looked at all the fuses and they seemed fine. Truck ran and everything seemed to work including my Scangauge II. I then disconnected the battery neg. terminal and let it sit for a while and then had no lights on the cluster when the battery was reconnected. I'm going to contact the local GM dealers this morning and see what can be done. Fortunately, I only have a little over 21K on the truck. Sure hope I can get this fixed quickly with all that's going on in the auto industry.

  10. #10
    Registered User
    Join Date
    Oct 2005
    Location
    Lakeland, Fla
    Posts
    11

    Re: 2003 Silverado Instrument Cluster Died

    Follow up to previous post - Took my truck to the local GM dealer yesterday morning, picked it up this afternoon. Replaced instrument cluster under warranty. Hope this one lasts. I usually keep vehicles till the wheels fall off so am hoping for no more problems.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •