GM Inside - Muscle Cars - Jeep

Support FSC and see no ads! - Click Here
Results 1 to 7 of 7

chevy k1500 runs rough cold and/or after rain,HELP!!

This is a discussion on chevy k1500 runs rough cold and/or after rain,HELP!! within the Technical / Maintenance forums, part of the General Discussion category; i have a 98 k1500 with a 5.7l in it.recently it started running really rough starting it up cold or ...

  1. #1
    Registered User
    Join Date
    Sep 2009
    Location
    huntingdon county,pa
    Posts
    4

    Question chevy k1500 runs rough cold and/or after rain,HELP!!


    Support FSC and see no ads! - Click Here
    i have a 98 k1500 with a 5.7l in it.recently it started running really rough starting it up cold or after it rained.it clears up after the motor warms up.i know the distributor cap isnt the problem.i changed the fuel filter recently.whenever it does it you can smell gas really bad like its flooding it until it warms up.it misses really bad when its cold too.like i said though it just happened outta the blue.just looking for some ideas what to check or what to look for considering i dont have the money to take it anywhere.any help or ideas are appreciated.

  2. #2
    Registered User
    Join Date
    Sep 2008
    Location
    ontario
    Posts
    130

    Re: chevy k1500 runs rough cold and/or after rain,HELP!!

    id say spark plug wires or even the plugs

  3. #3
    Registered User
    Join Date
    Mar 2007
    Location
    Edmonton
    Posts
    136

    Re: chevy k1500 runs rough cold and/or after rain,HELP!!

    could be your intake manifold pre warmer. it's not warming up the intake air so the fuel is not atomizing properly therefore not combusting properly. it could also be your charcoal canister is full of carbon. i would check this by disconnecting the hoses going to the canister and bypassing it to see if the conidition persists. if you haven't replaced your pcv valve in the last year i would do that too.

  4. #4
    0_o o_0 0_o o_0 98GreenMachine's Avatar
    Join Date
    Aug 2005
    Location
    St. Paul, MN
    Age
    29
    Posts
    5,583

    Re: chevy k1500 runs rough cold and/or after rain,HELP!!

    How do you know the distributor cap isn't the problem?
    08 HHR LS - 2.2 | 5 speed | 30 MPG

    98 K1500 Z71 - 204k | L31 | 60E | 3.73's | 3" BL | 33x12.5x15 Dick Cepek F-C II's | Dynomax Ultra Flo X DI/DO | 14 MPG

    84 S15 Jimmy 2dr 4x4 - engine/tranny all rebuilt

  5. #5
    Registered User
    Join Date
    Sep 2009
    Location
    huntingdon county,pa
    Posts
    4

    Re: chevy k1500 runs rough cold and/or after rain,HELP!!

    Quote Originally Posted by 98GreenMachine View Post
    How do you know the distributor cap isn't the problem?
    because i switched it with another one to check and there wasn't any corrision in the one thats in it.both ran the same.and the one i switched it with was about 3 to 4 months old and worked on what i got it off of.

  6. #6
    Registered User
    Join Date
    Sep 2009
    Location
    huntingdon county,pa
    Posts
    4

    Re: chevy k1500 runs rough cold and/or after rain,HELP!!

    i think i fixed it.i'll have to run it more and find out but i'm pretty sure the maf got dirty from over-oiling the k&n filter on it.and the wires were bad too.i looked at night and i could see them arcing.and considering the were the original ones i knew they needed changed.seemed to run good today after cleaning the maf sensor and putting new wires on.but last time i messed with it,it ran good and the next day ran like crap.so we'll see.

  7. #7
    Registered User
    Join Date
    Sep 2009
    Location
    huntingdon county,pa
    Posts
    4

    Re: chevy k1500 runs rough cold and/or after rain,HELP!!

    after cleaning the maf sensor and putting new plug wires and a pcv valve on it,it rained last night and once again runs rough atleast until it warms up.it misses at all rpm's when it does this.so now i'm stuck again.could the coil be getting wet and be bad?i noticed it seems to vibrate alot.i don't really notice the gas smell anymore just really running rough.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •