GM Inside - Ford Inside - Ford Ranger - Jeep - American Muscle

Support FSC and see no ads! - Click Here
Results 1 to 8 of 8

Sporadic bogging and sputtering 94 5.7 tbi 4l60e

This is a discussion on Sporadic bogging and sputtering 94 5.7 tbi 4l60e within the Technical / Maintenance forums, part of the General Discussion category; hey guys, first post here, i have a 94 chevy 1500 2wd, 5.7 tbi with a 4l60e , the truck ...

  1. #1
    Registered User
    Join Date
    Aug 2006
    Location
    NJ
    Posts
    6

    Sporadic bogging and sputtering 94 5.7 tbi 4l60e


    Support FSC and see no ads! - Click Here
    hey guys, first post here, i have a 94 chevy 1500 2wd, 5.7 tbi with a 4l60e , the truck is completely stock save for a monster performance rebuilt trans, it has a 1650 stall, my problem is that in overdrive between 40-50 mph when the truck is running like 1500 rpm's the motor just feels sluggish and bogs when you start to give it gas, if i run 3rd gear and shift manually into o/d at around 2000 rpm plus i have no problems, the truck pulls great, another problem is when im really getting on the truck and its at WOT, the truck sputters as its climbing in revs, this only happens when the truck is warm not cold, i have recently done a full tune up, and changed the fuel filter and air filter, when i replaced the trans i replaced the converter as well, i am wondering if my problem could lie in my stall speed, if perhaps i need a greater stall converter, my other idea was upping the rear gears to something like 3:73, i figure this will keep the motor out of that bad spot in the rpm range, it does not fix the sputtering rpm problem however, any info is appreciated, thanks

  2. #2
    G-FORCE FinalBreath's Avatar
    Join Date
    Sep 2007
    Location
    Milwaukee, WI
    Age
    27
    Posts
    1,648

    Re: Sporadic bogging and sputtering 94 5.7 tbi 4l60e

    Check the fuel pressure.
    88 K1500 5.7 220K SOLD
    95 K2500 5.7 336k SOLD
    96 K2500 6.5 171K
    06 Trailblazer LTZ

  3. #3
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    47
    Posts
    20,232

    Re: Sporadic bogging and sputtering 94 5.7 tbi 4l60e

    does the check engine light come on or flash briefly? if so you egr valve might be sticking open.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


  4. #4
    Registered User HUMP's Avatar
    Join Date
    Dec 2009
    Location
    Arkansas
    Posts
    119

    Re: Sporadic bogging and sputtering 94 5.7 tbi 4l60e

    Just something else that gets overlooked(I know from experience)the pickup coil on the distributor shaft can cause the same symptoms.I posted this somewhere else,but mine ran like the distributor was wet every so often or the tranny was going out until it just quit( chased it for 2 days).The nylon body of the coil that slips over the distributor shaft seems to twist some and gradually pull on the wires until they lose connection.Like I said,just throwing that out there.

  5. #5
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    47
    Posts
    20,232

    Re: Sporadic bogging and sputtering 94 5.7 tbi 4l60e

    pickup coil is an easy check. set multimeter to ohms. disconnect pickup coil wires from module. should be between 500-1500 ohms.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


  6. #6
    Registered User
    Join Date
    Aug 2006
    Location
    NJ
    Posts
    6

    Re: Sporadic bogging and sputtering 94 5.7 tbi 4l60e

    fuel pressure is good, no check engine lights or flashing , ill check the pickup coil ......thanks for the tips

  7. #7
    Registered User
    Join Date
    Nov 2006
    Location
    CHEVY HEAVEN ,SUBZERO
    Posts
    122

    Re: Sporadic bogging and sputtering 94 5.7 tbi 4l60e

    ummm you could also have a glitch in the TPS...this could cause the sputtering action your talking about..

  8. #8
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    47
    Posts
    20,232

    Re: Sporadic bogging and sputtering 94 5.7 tbi 4l60e

    its also easy to test the tps sensor with a multimeter. set multimeter to dc volts. probe dark blue wire with red lead(needle probe, leave sensor connected). ignition on engine stopped. voltage should be around .5vdc. slowly open throttle, voltage should increase up to 5vdc at WOT. should be no flat or dead spots. also no erratic voltages.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •