GM Inside - Ford Inside - Ford Ranger - Jeep - American Muscle

Support FSC and see no ads! - Click Here
Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Heater only blows luke warm air

This is a discussion on Heater only blows luke warm air within the Technical / Maintenance forums, part of the General Discussion category; The heater is my 99 nbs won't blow really hot air like my smaller ranger. What do I need to ...

  1. #1
    Chevy newbie 99silveradoLS's Avatar
    Join Date
    Dec 2008
    Location
    Missouri
    Age
    28
    Posts
    100

    Heater only blows luke warm air


    Support FSC and see no ads! - Click Here
    The heater is my 99 nbs won't blow really hot air like my smaller ranger. What do I need to look at or have serviced? I read somewhere that a clogged cabin air filter could cause this but haven't checked that yet because it's been frigging cold outside and I've been driving my Ranger.
    1999 Silverado LS 4x4 Z71 w/ 5.3L

  2. #2
    Head Cook mrgrim's Avatar
    Join Date
    Jun 2008
    Location
    Philly
    Posts
    619

    Re: Heater only blows luke warm air

    Is the truck warming up to normal motor temp? Coolant full? heater core and air box full of dirt? Blend door moving all the way?

    Thats where I would start
    04 ECSB 5.3 4x4 Z71
    06 Front clip, Reflexion steel hood, Escalade touch screen nav, Escalade wood steering wheel
    06 E Fans and Rad, 2 Alpine subs, 250 amp MechMan alternator, Dual battery with isolator
    " Self Jump Starts Rock" Line X, Open country AT2, PCM4Less tune and learning HP Tuners

  3. #3
    Chevy newbie 99silveradoLS's Avatar
    Join Date
    Dec 2008
    Location
    Missouri
    Age
    28
    Posts
    100

    Re: Heater only blows luke warm air

    Thanks for the starting points.

    The truck warms up normal. Coolant is full. I will check the air box and heater core. What's the blend door?
    1999 Silverado LS 4x4 Z71 w/ 5.3L

  4. #4
    Big Jake BigJake's Avatar
    Join Date
    Sep 2006
    Location
    louisiana
    Posts
    84

    Re: Heater only blows luke warm air

    My son had this problem on his 02 Z71. He removed the hoses from the heater core and blew it out with air and then a water hose. Heater core was restricted. Works great now.
    2004 2500 ccsb 6.0, Superchips, 265/75/16 Toyo A/T's.

  5. #5
    Registered User Tweaks's Avatar
    Join Date
    Sep 2007
    Location
    Cape Cod, MA
    Age
    33
    Posts
    3,921

    Re: Heater only blows luke warm air

    This is the time of year when this sort of thing becomes very common. NBS trucks typically suffer from either clogged cabin air filters or a clogged heater core, or maybe both at the same time. The heater core back flush is very easy to do, and if that doesn't resolve things, go after the cabin air filters.
    00 RCSB Z71/JBA cat-back/Z71 Tahoe valance/EBC slotted&drilled rotors with SS lines & SS braided hoses/Edelbrock headers/BB tune/6000k HID low beam & fog lamps/Auto-headlight disable mod(nice)/Vette servo/LT1 E-fans/LED gauge cluster/Titan 18" wheels/Rollpan/Belltech rear sway bar/2-4 drop

  6. #6
    Chevy newbie 99silveradoLS's Avatar
    Join Date
    Dec 2008
    Location
    Missouri
    Age
    28
    Posts
    100

    Re: Heater only blows luke warm air

    Well I just changed the cabin air filters and you were right, they were FILTHY! I doubt they have ever been changed and truck is 11 years old with 200k miles. I'll let you know if that fixes the heating issue. I'm hoping it does since they were so nasty.
    1999 Silverado LS 4x4 Z71 w/ 5.3L

  7. #7
    Registered User Tweaks's Avatar
    Join Date
    Sep 2007
    Location
    Cape Cod, MA
    Age
    33
    Posts
    3,921

    Re: Heater only blows luke warm air

    No heat usually means a clogged heater core if everything else is fine. Warm, but not hot air, is usually a pair of clogged cabin filters. I bet replacing your filters has made a big difference.
    00 RCSB Z71/JBA cat-back/Z71 Tahoe valance/EBC slotted&drilled rotors with SS lines & SS braided hoses/Edelbrock headers/BB tune/6000k HID low beam & fog lamps/Auto-headlight disable mod(nice)/Vette servo/LT1 E-fans/LED gauge cluster/Titan 18" wheels/Rollpan/Belltech rear sway bar/2-4 drop

  8. #8
    Registered User
    Join Date
    May 2006
    Location
    MA
    Posts
    16

    Re: Heater only blows luke warm air

    The heater core probably needs to be bled. If the core is full of fluid and there is air in the feed side (WP Out) hose the air will act like a spring. The air will compress, but the WP doesn't have enough "Umph" to push the air bubble combined with the weight of the fluid inside the core w/out winding the pi$$ out of the motor. I take the hoses off the core and blow the fluid out of the core using compressed air. Be careful, the fluid will spray all over the engine if you don't do something with the other tube. I usually use a large towel. Reconnect the hoses, add fluid and run the engine.

  9. #9
    Registered User
    Join Date
    Aug 2002
    Location
    SYRACUSE NY & ALEXANDRIA BAY NY
    Posts
    1,346

    Re: Heater only blows luke warm air

    I would try a blend door reset ! Its easy and free:

    It is most likely the Blend door actuator.

    BUT before you go to the dealer try the reset procedure thats
    been floating around on the GM forums:

    Try looking for the HVAC fuse under the hood.
    pull the fuse for about five minutes, reinstall it then turn the ignition on don't touch the controls for another 5 minutes. The system will run through all the settings.

  10. #10
    Rest In Peace #3 intimidator4x4's Avatar
    Join Date
    Dec 2007
    Location
    Southeastern Indiana
    Age
    45
    Posts
    1,727

    Re: Heater only blows luke warm air

    Does this reset work on the pre 99 trucks (OBS)
    V INTIMIDATOR has been SOLD V

    98 RCLB Z71 all stock

  11. #11
    Registered User swb lt1's Avatar
    Join Date
    Nov 2009
    Location
    arlington, tx
    Posts
    173

    Re: Heater only blows luke warm air

    i would try blowing air through it first. just disconnect both of the hoses and blow air through one side of it. i had this problem and this fixed mine, it was just clogged up.

    1993 GMC SIERRA with 1996 corvette lt1. Built 4l60e. 4.10 gears. Eaton positrac. Dual exhaust. 1996 dash swap. 2002 electric tahoe seats. More to come

  12. #12
    Chevy newbie 99silveradoLS's Avatar
    Join Date
    Dec 2008
    Location
    Missouri
    Age
    28
    Posts
    100

    Re: Heater only blows luke warm air

    It made a pretty good difference in the amount of heat that it puts out now. It's not super hot like in some trucks, but it's warm enough now that I get uncomfortable if I wear anything besides a shirt when the heat is on.
    1999 Silverado LS 4x4 Z71 w/ 5.3L

  13. #13
    Registered User Afterdark's Avatar
    Join Date
    Mar 2006
    Location
    idaho
    Posts
    29

    Re: Heater only blows luke warm air

    take the two hoses going to the heater core and swap them for a couple days prob the dex cool (evil satan juice) pluging up in the core if so this works every time :)

  14. #14
    Registered User
    Join Date
    Sep 2009
    Location
    Indiana
    Posts
    1

    Re: Heater only blows luke warm air

    You just might need a new thermostat.

  15. #15
    so cheap it's scary Stratosman's Avatar
    Join Date
    Oct 2007
    Location
    Kentucky
    Age
    38
    Posts
    5,410

    Re: Heater only blows luke warm air

    which FSC's came with a cabin filter?

    Used to own a FSC, now I just have my extremely old Buick.
    Have some perspective please. Thank you.

  16. #16
    Chevy newbie 99silveradoLS's Avatar
    Join Date
    Dec 2008
    Location
    Missouri
    Age
    28
    Posts
    100

    Re: Heater only blows luke warm air

    It got a new thermostat put on last year. I'm going to do the heater core flush still and see if that helps even more as well as due a full coolant flush and clean because it needs it. My truck is a 99 NBS and it has the two cabin air filters. From what I read it was the 99-02 nbs trucks that had them.
    1999 Silverado LS 4x4 Z71 w/ 5.3L

  17. #17
    Registered User swb lt1's Avatar
    Join Date
    Nov 2009
    Location
    arlington, tx
    Posts
    173

    Re: Heater only blows luke warm air

    i would almost put money on the fact that the heater core is probably clogged. just shoot some air through it from both ways and hold a rag on the opposite pipe each time and see what kind of nasty crap gets blown onto the rag.

    1993 GMC SIERRA with 1996 corvette lt1. Built 4l60e. 4.10 gears. Eaton positrac. Dual exhaust. 1996 dash swap. 2002 electric tahoe seats. More to come

  18. #18
    Honorary Mythbuster neonhomer's Avatar
    Join Date
    Sep 2007
    Location
    Volusia County, FL
    Age
    37
    Posts
    333

    Re: Heater only blows luke warm air

    Here is a twist. I had to clean my negative battery cable. When I put it all back together, the heat doesn't work anymore. It worked fine before I did the cable cleaning. I am going to try to do an air door reset and see if it helps...
    NeonHomer

    2004 Chevy Silverado 1500 2WD Ext. Cab 5.3L/4spd
    1994 Dodge Caravan 3.0L/4spd
    2004 Harley-Davidson Road King Police FLHP/I

  19. #19
    Registered User
    Join Date
    Feb 2010
    Location
    Millbury, Ma
    Posts
    23

    Re: Heater only blows luke warm air

    its sounds like the heatercore is clogged. the stock fluid gm used for a short peroid of time ate away at the heatercore which was causing the problem you are having. i had the same problem on my 2000 and i flushed the heater core now it works great.

  20. #20
    Chevy newbie 99silveradoLS's Avatar
    Join Date
    Dec 2008
    Location
    Missouri
    Age
    28
    Posts
    100

    Re: Heater only blows luke warm air

    Should I disconnect the hoses from the water pump and flush from there or get a quick disconnect tool and remove the hoses from the heater core and flush from there? Does Oreilly's carry the tool for disconnecting the hoses? We accidently broke the inlet hose the other day changing the intake gaskets and ended up just using a screw clamp to secure it back to the heater core pipe because the quick disconnect tool that we had on hand wasn't working. I'm thinking it maybe wasn't "long" enough to unclip the "quick disconnect".
    Last edited by 99silveradoLS; 02-16-2010 at 02:14 PM.
    1999 Silverado LS 4x4 Z71 w/ 5.3L

 

 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •