GM Inside - Ford Inside - Ford Ranger - Jeep - American Muscle

Support FSC and see no ads! - Click Here
Page 1 of 3 123 LastLast
Results 1 to 20 of 48

93 K1500 No Spark

This is a discussion on 93 K1500 No Spark within the Technical / Maintenance forums, part of the General Discussion category; I have a '93 Chevy K1500. It was idling and then shut off. I now have no spark at all. ...

  1. #1
    Registered User
    Join Date
    Jan 2010
    Location
    Tampa, FL
    Posts
    42

    93 K1500 No Spark


    Support FSC and see no ads! - Click Here
    I have a '93 Chevy K1500. It was idling and then shut off. I now have no spark at all. Any thoughts?
    I replaced the ignition switch, and the purple wire from the ignition switch got real hot and burned some of the shielding off. It turns over with no issue, but still has no spark....Crank sensor?

  2. #2
    No More Mr Niceguy xch3no2's Avatar
    Join Date
    Sep 2009
    Location
    Pacific NW
    Posts
    1,245

    Re: 93 K1500 No Spark

    Check under your dist cap for any ugliness. Most parts stores can test the ignition module (kinda).
    Last edited by xch3no2; 01-04-2010 at 11:08 PM.
    89 K3500 RCLB- Fat Snarling RAT..Scat/Eagle/Crower/Crane/Edelbrock/MSD..TBI/EBL/TH400/Dana 60

  3. #3
    They're coming for us 1988 GMC 355's Avatar
    Join Date
    Jun 2008
    Location
    Union, Missouri
    Age
    23
    Posts
    10,250

    Re: 93 K1500 No Spark

    x2 on the ign module

    '95 GMC Z71|L05|GT4|Yukon 17s|Belltech|Purple Keys|FastChip|Hedman|Borla |XtremeFI|Goodmark|Kenwood|Memphis|Ultimate TBI Mods|E Fan|
    Yes it is a 4x4, yes it is lowered

    5200 lbs. at 13.0/17.0MPG
    1988 GMC SOLD

  4. #4
    proud poppa reesez's Avatar
    Join Date
    Apr 2008
    Location
    shelbyville, indiana
    Posts
    316

    Re: 93 K1500 No Spark

    Quote Originally Posted by mudbuddy View Post
    if you let the smoke out of the wire you have a short. You will need to deal with that first.
    +1

    1994 yukon gt .........gone but not forgotten
    1988 silverado RCLB 4wd........sold
    1999 rcsb gmc sierra 1500, new toy

  5. #5
    Registered User
    Join Date
    Jan 2010
    Location
    Tampa, FL
    Posts
    42

    Re: 93 K1500 No Spark

    Quote Originally Posted by 1988 GMC 355 View Post
    x2 on the ign module
    Just got the truck so I will ask..where is the ignition module located?

  6. #6
    TEE
    TEE is offline
    Registered User
    Join Date
    Sep 2006
    Location
    fairborn,ohio
    Age
    54
    Posts
    1,353

    Re: 93 K1500 No Spark

    Under the dizzy...also check the magnet on top to check for cracks.
    If it does...it's time for a new dizzy.
    At least that was my case on my 94.

  7. #7
    Registered User
    Join Date
    Jan 2010
    Location
    Tampa, FL
    Posts
    42

    Re: 93 K1500 No Spark

    Quote Originally Posted by TEE View Post
    Under the dizzy...also check the magnet on top to check for cracks.
    If it does...it's time for a new dizzy.
    At least that was my case on my 94.
    Dizzy = Distributor cap?

  8. #8
    TEE
    TEE is offline
    Registered User
    Join Date
    Sep 2006
    Location
    fairborn,ohio
    Age
    54
    Posts
    1,353

    Re: 93 K1500 No Spark

    yes...the magnet on top gets cracks in it which will not let the distributor pop up.
    If you do replace it...the new one will NOT look like the old one.
    They did away with that type of mag.
    Last edited by TEE; 01-05-2010 at 07:05 AM.

  9. #9
    Registered User
    Join Date
    Jan 2010
    Location
    Tampa, FL
    Posts
    42

    Re: 93 K1500 No Spark

    So what is this? It attaches via a cable to the Distributor. I am guessing the pink wire is the same one that heads to the Ignition switch on the Column. You can see it is slightly burnt at the head.
    Could this thing be the issue of why there is no spark?

    Last edited by ipstack; 01-05-2010 at 09:06 AM. Reason: Adding Pics

  10. #10
    You won't like my tastes Swims350's Avatar
    Join Date
    Dec 2009
    Location
    Logan WV
    Posts
    2,538

    Re: 93 K1500 No Spark

    that's the coil or ign. coil it can be tested as well, won't hurt anything.

    The ign. module is under the cap, take it off, and down in the bottom on the metal part is a module that's held on by 2 small bolts and a plugin.

  11. #11
    tee-boy
    Join Date
    Apr 2005
    Location
    texas
    Posts
    660

    Re: 93 K1500 No Spark

    that pink wire is the ignition wire from the ignition switch. It is hot when key is in run or start position. You have a red wire to the ignition switch on all GM's (battery power in) and pink is (ignition out to the ignition system (Distributor on an OBS).

    the ignition module (electronic ign module) opens and closes the circuit for the coil (it takes place of mechanical points used in older vehicles).

    I would test the pink wire w/ a test light. if it checks out, it is either the module, coil, or the distributor.
    Last edited by tee-boy; 01-05-2010 at 09:50 AM.
    94 Silverado 2WD; 284K miles; Built 4L60E

    98 Trans Am; TH 400; 4400 Stall; F.A.S.T. 90; SS Long Tubes; BMR rear adjustable suspension; Slicks and Skinnies on Bogarts; Electric Water Pump; 11.50 1/4 mile; 400 lbs weight reduction; Underdriven; Stock valvetrain (Always a Work in Progress)

  12. #12
    Registered User
    Join Date
    Jan 2010
    Location
    Tampa, FL
    Posts
    42

    Re: 93 K1500 No Spark

    So basically see if there is voltage up to the top of the coil on the pink wire with the key in the "on" position

  13. #13
    They're coming for us 1988 GMC 355's Avatar
    Join Date
    Jun 2008
    Location
    Union, Missouri
    Age
    23
    Posts
    10,250

    Re: 93 K1500 No Spark

    Yes that is correct.

    THat wire looks pretty bad too, I would try to replace or fix it so it doesnt short again.

    and a new coil, distributor cap and rotor may not be a bad idea either.

    '95 GMC Z71|L05|GT4|Yukon 17s|Belltech|Purple Keys|FastChip|Hedman|Borla |XtremeFI|Goodmark|Kenwood|Memphis|Ultimate TBI Mods|E Fan|
    Yes it is a 4x4, yes it is lowered

    5200 lbs. at 13.0/17.0MPG
    1988 GMC SOLD

  14. #14
    Registered User
    Join Date
    Jan 2010
    Location
    Tampa, FL
    Posts
    42

    Re: 93 K1500 No Spark

    I do have voltage up to the top of the coil. I want to replace that wire, is it a direct run from the Ignition switch to the connector on the coil? So I am going to just replace the Coil, Dist Cap, Rotor Cap, IGN.

  15. #15
    Registered User
    Join Date
    Mar 2007
    Location
    MI/AZ
    Posts
    5,541

    Re: 93 K1500 No Spark

    Something has rubbed on the wire, the aircleaner will if the spacer isnt on the TB or an aftermarket air cleaner.
    04 K1500 Silverado EXT 3:73 gears, 5.3L 265/75-16,Pace Edwards tonneau,

  16. #16
    Registered User
    Join Date
    Jan 2010
    Location
    Tampa, FL
    Posts
    42

    Re: 93 K1500 No Spark

    Could be, there is a K&N Air Filter on there. Would that cause it to short causing the no spark?

  17. #17
    Registered User
    Join Date
    Mar 2007
    Location
    MI/AZ
    Posts
    5,541

    Re: 93 K1500 No Spark

    Quote Originally Posted by ipstack View Post
    Could be, there is a K&N Air Filter on there. Would that cause it to short causing the no spark?
    Is it an aftermarket air cleaner housing? If so its hitting the pos/pink wire and grounding out on the air cleaner housing.
    04 K1500 Silverado EXT 3:73 gears, 5.3L 265/75-16,Pace Edwards tonneau,

  18. #18
    tee-boy
    Join Date
    Apr 2005
    Location
    texas
    Posts
    660

    Re: 93 K1500 No Spark

    Quote Originally Posted by ipstack View Post
    I do have voltage up to the top of the coil. I want to replace that wire, is it a direct run from the Ignition switch to the connector on the coil? So I am going to just replace the Coil, Dist Cap, Rotor Cap, IGN.
    Coil, Dist cap, rotor - all cheap fixes. If you change the ingnition module and it winds up being the distributor, you still haven't fixed the problem.
    94 Silverado 2WD; 284K miles; Built 4L60E

    98 Trans Am; TH 400; 4400 Stall; F.A.S.T. 90; SS Long Tubes; BMR rear adjustable suspension; Slicks and Skinnies on Bogarts; Electric Water Pump; 11.50 1/4 mile; 400 lbs weight reduction; Underdriven; Stock valvetrain (Always a Work in Progress)

  19. #19
    They're coming for us 1988 GMC 355's Avatar
    Join Date
    Jun 2008
    Location
    Union, Missouri
    Age
    23
    Posts
    10,250

    Re: 93 K1500 No Spark

    Quote Originally Posted by ipstack View Post
    I do have voltage up to the top of the coil. I want to replace that wire, is it a direct run from the Ignition switch to the connector on the coil? So I am going to just replace the Coil, Dist Cap, Rotor Cap, IGN.
    that is a good start, considering you just got the truck and you should replace that stuff any way.

    you can get taht wire from the dealer or an auto parts store I am sure.

    '95 GMC Z71|L05|GT4|Yukon 17s|Belltech|Purple Keys|FastChip|Hedman|Borla |XtremeFI|Goodmark|Kenwood|Memphis|Ultimate TBI Mods|E Fan|
    Yes it is a 4x4, yes it is lowered

    5200 lbs. at 13.0/17.0MPG
    1988 GMC SOLD

  20. #20
    tee-boy
    Join Date
    Apr 2005
    Location
    texas
    Posts
    660

    Re: 93 K1500 No Spark

    could be the wire that runs from the coil secondary to the dist cap (typically purchased when you purchase plug wires - may not be bad idea to change those while your at it).
    Last edited by tee-boy; 01-05-2010 at 03:04 PM.
    94 Silverado 2WD; 284K miles; Built 4L60E

    98 Trans Am; TH 400; 4400 Stall; F.A.S.T. 90; SS Long Tubes; BMR rear adjustable suspension; Slicks and Skinnies on Bogarts; Electric Water Pump; 11.50 1/4 mile; 400 lbs weight reduction; Underdriven; Stock valvetrain (Always a Work in Progress)

 

 
Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •