If you are not able to login to the forum, please Contact Us here to let us know. Thanks!

Support FSC and see no ads! - Click Here
Results 1 to 10 of 10

ECM problem :cussing: 95 Chevy 1500 5.7L

This is a discussion on ECM problem :cussing: 95 Chevy 1500 5.7L within the Technical / Maintenance forums, part of the General Discussion category; Have a 95 Chevy 1500 5.7L and all of a sudden everything is going wacky. The speedometer, fuel gauge, tachometer... ...

  1. #1
    Registered User
    Join Date
    Feb 2010
    Location
    Holloman AFB
    Posts
    8

    ECM problem 95 Chevy 1500 5.7L


    Support FSC and see no ads! - Click Here
    Have a 95 Chevy 1500 5.7L and all of a sudden everything is going wacky. The speedometer, fuel gauge, tachometer... My ECM needs to be replaced, and I have verified that I have the common ECM (16197427). Should I just go to Autozone and buy a replacement? If so, does anyone have experience with this, and are there any obstacles? They were telling me that once I bring in the core I will only end up paying like $80. I am not good with PROM's, and have no experience with these either although I know they sit inside the ECM. I do not think this needs replaced, I think it is the whole circuit board that has gone bad. Any input is appreciated.
    Last edited by kowalczyk86; 02-11-2010 at 09:43 PM.

  2. #2
    Registered User J-Dog's Avatar
    Join Date
    Feb 2010
    Location
    White Bear Lake, Minnesota
    Age
    48
    Posts
    226

    Re: ECM problem :cussing: 95 Chevy 1500 5.7L

    You know that's a 95'and I'm sure you would have no problem finding the hole unit in one of your local bone yards. It Wouldn't hurt to call around for one that way if your not sure of your ability? good luck"

  3. #3
    Registered User para driver's Avatar
    Join Date
    May 2009
    Location
    Dallas
    Posts
    564

    Re: ECM problem :cussing: 95 Chevy 1500 5.7L

    eBay for about $30, vendor named Ragged...
    '95 Tahoe LT 4x4, TBI with Vortec crate motor.
    God created all men, and Sam Colt made them equal.

  4. #4
    Registered User
    Join Date
    Apr 2007
    Location
    Kansas City MO
    Age
    33
    Posts
    543

    Re: ECM problem :cussing: 95 Chevy 1500 5.7L

    Are you sure the charging system is working properly?
    89' K2500 SLE 350/700R4 ECLB 270K 4:10 gears Dual Efans
    Rebuilt tranny, all new AC parts. 95 mirrors, 6.5's in the doors.
    Soon: 94' instrument cluster and power window/locks

  5. #5
    Registered User
    Join Date
    Feb 2010
    Location
    Holloman AFB
    Posts
    8

    Re: ECM problem :cussing: 95 Chevy 1500 5.7L

    I posted this for my Dad 1,400 miles away. He is a pretty top notch mechanic, but not so top notch when it comes to computers. I believe the charging system is working fine, but I will ask him tonight. He said that the transmission is also acting weird.

  6. #6
    Loves GMT400 haters someotherguy's Avatar
    Join Date
    Aug 2005
    Location
    somewhere else
    Posts
    11,099

    Re: ECM problem :cussing: 95 Chevy 1500 5.7L

    I seriously doubt it's the PCM, more likely to be the ignition switch (somewhat common failure on the 95-up), but some more troubleshooting would be a good idea before just throwing parts at it.

    In fact I'd bet money that replacing the PCM alone will not fix this issue.

    Richard

  7. #7
    Registered User
    Join Date
    Feb 2010
    Location
    Holloman AFB
    Posts
    8

    Re: ECM problem :cussing: 95 Chevy 1500 5.7L

    Thank for everyones help. I will relay the info. I think it's important to add that this all started happening instantaneously.

  8. #8
    Registered User
    Join Date
    Feb 2010
    Location
    Holloman AFB
    Posts
    8

    Re: ECM problem :cussing: 95 Chevy 1500 5.7L

    UPDATE: I posted a new thread also, to catch some more attention:

    After installing the new ECM from autozone:


    Start the truck up and the tachometer is working.. The light for the gear shift indicator is on. Whenever you put the brake on and put in gear, the tachometer drops off. The truck doesn't have any power to run. I have to start in Low 1 to get it moving.. Gas gauge is fluctuating.

    Prior to installing the new ECM I was having the same problems, but when I installed the new one, my truck seemed like it was good to go. Shortly after that I was having the same problems. I bought the re manufactured ECM from autozone. Any help is appreciated.

    GM said it might be the instrument cluster. Do I need to replace this?

    (Posting this for my Dad). Any help is appreciated.

  9. #9
    Registered User
    Join Date
    Apr 2007
    Location
    Kansas City MO
    Age
    33
    Posts
    543

    Re: ECM problem :cussing: 95 Chevy 1500 5.7L

    Toss another cluster in there. Easy enough to do.
    89' K2500 SLE 350/700R4 ECLB 270K 4:10 gears Dual Efans
    Rebuilt tranny, all new AC parts. 95 mirrors, 6.5's in the doors.
    Soon: 94' instrument cluster and power window/locks

  10. #10
    Registered User para driver's Avatar
    Join Date
    May 2009
    Location
    Dallas
    Posts
    564

    Re: ECM problem :cussing: 95 Chevy 1500 5.7L

    check all your ground wires before spending any more money on this... you may have one making intermittent contact, and that will screw the whole thing up.
    '95 Tahoe LT 4x4, TBI with Vortec crate motor.
    God created all men, and Sam Colt made them equal.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •