If you are not able to login to the forum, please Contact Us here to let us know. Thanks!

Support FSC and see no ads! - Click Here
Results 1 to 15 of 15

94' silverado loses all power--then is fine again

This is a discussion on 94' silverado loses all power--then is fine again within the Technical / Maintenance forums, part of the General Discussion category; ok this is driving everybody crazy--94' silverado 1500 ,after the truck warms up it starts to cut out .when i ...

  1. #1
    Registered User
    Join Date
    Mar 2010
    Location
    oly,pia
    Posts
    5

    94' silverado loses all power--then is fine again


    Support FSC and see no ads! - Click Here
    ok this is driving everybody crazy--94' silverado 1500 ,after the truck warms up it starts to cut out .when i give it more gas it does not react but after a few seconds it all catches up and goes for a couple of minutes and then boom--cuts out and does it again-.all engine codes have been addresed and the list of things replaced is quite long. I had a certified mechanic drive it and he did not know what the problem was either.ANYBODY that has had this problem and figured it out I would be forever grateful-

  2. #2
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    48
    Posts
    20,821

    Re: 94' silverado loses all power--then is fine again

    list out the things replaced.
    cts sensor or 02 sensor could cause problems after warm up. fuel pressure good when warm?
    Last edited by NEUMANNZZ; 03-17-2010 at 12:06 PM.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


  3. #3
    Registered User The-Redneck's Avatar
    Join Date
    Mar 2010
    Location
    Red Deer, Alberta
    Posts
    51

    Re: 94' silverado loses all power--then is fine again

    fuel filter.
    1995 GMC Sierra 2500 4x4 5.7L 5 speed manual W/T

  4. #4
    Registered User
    Join Date
    Mar 2010
    Location
    oly,pia
    Posts
    5

    Re: 94' silverado loses all power--then is fine again

    here is the list of replaced items
    iav valve
    egr solenoid
    map sensor
    o2 sensor
    temp sensor
    temp sender
    fuel injectors
    fuel pressure regulator
    fuel sending unit w/ pump
    ecu
    prom
    tps
    fuel filter
    new plugs
    plug wires
    new dist cap/w rotor
    factory rebuilt transmission

    as you can see this is becoming quite irratating and it is not something simple like the fuel filter-hence the driving me crazy part-

  5. #5
    Registered User
    Join Date
    Mar 2010
    Location
    oly,pia
    Posts
    5

    Re: 94' silverado loses all power--then is fine again

    fuel pressure is fine when warm- this has really got me stumped-

  6. #6
    Registered User HUMP's Avatar
    Join Date
    Dec 2009
    Location
    Arkansas
    Posts
    119

    Re: 94' silverado loses all power--then is fine again

    Have the coil and pickup been checked?

  7. #7
    Registered User
    Join Date
    Mar 2010
    Location
    oly,pia
    Posts
    5

    Re: 94' silverado loses all power--then is fine again

    coil is new pick is fine also--one more thing I can add that might be of help is that it all started after a new exhaust system-not sure if it has anything to do with it or is mere coincidence

  8. #8
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    48
    Posts
    20,821

    Re: 94' silverado loses all power--then is fine again

    maybe they damaged the o2 sensor welding on the exhaust, or the sensor wires rubbing on the exhaust and melting.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


  9. #9
    Registered User
    Join Date
    Mar 2010
    Location
    oly,pia
    Posts
    5

    Re: 94' silverado loses all power--then is fine again

    well will check the sensor -dont suppose you know an easy way of doing that do ya ? umm say ....like what the voltage is supposed to be ?

  10. #10
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    48
    Posts
    20,821

    Re: 94' silverado loses all power--then is fine again

    your gonna need a scan tool to check o2 sensor operation. I would at least look under there and check the wiring.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


  11. #11
    Registered User Dev's93's Avatar
    Join Date
    Mar 2010
    Location
    Shelbyville , IN
    Age
    30
    Posts
    1,032

    Re: 94' silverado loses all power--then is fine again

    ignition switch?

  12. #12
    Registered User
    Join Date
    Sep 2006
    Location
    Arizona
    Posts
    23

    Re: 94' silverado loses all power--then is fine again

    electronic ignition module

  13. #13
    OBS Obsessed 94Z-Buggy's Avatar
    Join Date
    Dec 2007
    Location
    La Grange, NC
    Age
    29
    Posts
    255

    Re: 94' silverado loses all power--then is fine again

    an o2 sensor is not that intricute in the operation of an OBD 1 system. i had a 94 burb that had no o2 sensor on it, drove it like that for about a year, it just makes the truck run a little rich and have an aggrivating orange glow coming from the dash.
    1994 Chevrolet Silverado Z71 ECSB
    3" lift-305/70R17 Buckshots-17x10 Gear Alloy Modified-True Duals-Smoke Tint
    227K on the clock


  14. #14
    Registered User
    Join Date
    Aug 2003
    Location
    Virginia
    Posts
    9

    Re: 94' silverado loses all power--then is fine again

    Did you ever resolve this issue? i have a 98 silverado and i'm going down this same road....Wont throw any generic codes with service engine light, but i know something is wrong...I hate to take to pay for diagnostic scanning when it could be a simple sensor....Any insight appreciated..
    Scott Freeman

  15. #15
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    48
    Posts
    20,821

    Re: 94' silverado loses all power--then is fine again

    Quote Originally Posted by smfreema View Post
    Did you ever resolve this issue? i have a 98 silverado and i'm going down this same road....Wont throw any generic codes with service engine light, but i know something is wrong...I hate to take to pay for diagnostic scanning when it could be a simple sensor....Any insight appreciated..
    his truck is tbi, totally different fuel injection and computer system. start a new thread.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •