GM Inside - Ford Inside - Ford Ranger - Jeep - American Muscle

Support FSC and see no ads! - Click Here
Results 1 to 10 of 10

Hesitation/Runs Rough when warm and only a cruise speed

This is a discussion on Hesitation/Runs Rough when warm and only a cruise speed within the Technical / Maintenance forums, part of the General Discussion category; 1990 K2500 5.7L TBI I appreciate any advice. My truck runs really rough and hesitates only after the engine has ...

  1. #1
    Registered User
    Join Date
    Jul 2010
    Location
    Fort Wayne
    Posts
    20

    Hesitation/Runs Rough when warm and only a cruise speed


    Support FSC and see no ads! - Click Here
    1990 K2500 5.7L TBI

    I appreciate any advice. My truck runs really rough and hesitates only after the engine has warmed up and only when I have slight pressure on the gas pedal. I don't notice any hesitation when accelerating. I don't really notice it at slower speeds either (but I'm not 100% sure if it isn't happening). But if I try and hold the speed at 55 mph, it hesitates and jerks, etc.

    Thanks!

  2. #2
    Workin on a loapy 383 Hicks-MofG's Avatar
    Join Date
    Mar 2007
    Location
    Kentucky
    Age
    31
    Posts
    833

    Re: Hesitation/Runs Rough when warm and only a cruise speed

    Check the EGR system.... make sure its not drawing air. that could lean it out.
    WIP-1997 K2500 Ext Cab
    Volant CAI-BBK 85mm TB-Marine intake-32Lbs Injectors
    Patriot Vortec 185cc, Comp 1.6RR, 224/230-573/568 LSA113
    KB Pistons Thermal/Friction Coated, SCAT 383 Rotating, 6" Rods
    MSD Digital 6, HVCII Coil, 2200-2600 Stall, E-Fan, UD pulleys....


    http://prosilversystems.com

  3. #3
    Registered User
    Join Date
    Jul 2010
    Location
    Fort Wayne
    Posts
    20

    Re: Hesitation/Runs Rough when warm and only a cruise speed

    Quote Originally Posted by Hicks-MofG View Post
    Check the EGR system.... make sure its not drawing air. that could lean it out.
    Thanks. I did check the egr valve. It seems to be working fine. I did unplug the vacuum line from the egr valve and it still has the hesitation problem. Any other thoughts on how to check out the egr system?

  4. #4
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    47
    Posts
    20,242

    Re: Hesitation/Runs Rough when warm and only a cruise speed

    does the check engine light come on and then goes off during the hesitation?
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


  5. #5
    Full time lurker jerome99's Avatar
    Join Date
    May 2005
    Location
    Little Rock
    Age
    30
    Posts
    126

    Re: Hesitation/Runs Rough when warm and only a cruise speed

    Thats the same thing mine is doing. NEUMANNZZ is a good resource, smart guy.

    My truck is a money pit with no bottom.
    1996 K1500 5.7 Vortec

  6. #6
    Registered User
    Join Date
    Jul 2010
    Location
    Fort Wayne
    Posts
    20

    Re: Hesitation/Runs Rough when warm and only a cruise speed

    Quote Originally Posted by NEUMANNZZ View Post
    does the check engine light come on and then goes off during the hesitation?
    The check engine light does come on sometimes, but not right when the hesitations start. If I drive it for a long time, the check engine light comes on, but when I start it up again after shutting it off, it is gone.

    I don't know if it is related, but this truck idles extremely high when in park...
    Last edited by dosnotches; 11-10-2010 at 05:25 PM.

  7. #7
    Registered User
    Join Date
    Jul 2010
    Location
    Fort Wayne
    Posts
    20

    Re: Hesitation/Runs Rough when warm and only a cruise speed

    I do think it is EGR related now. I pulled the vacuum hose from the egr valve and plugged it up. I'm not getting any of the hesitations now...

    Quote Originally Posted by Hicks-MofG View Post
    Check the EGR system.... make sure its not drawing air. that could lean it out.

  8. #8
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    47
    Posts
    20,242

    Re: Hesitation/Runs Rough when warm and only a cruise speed

    replace the egr valve with an oem. not autozone crap.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


  9. #9
    Registered User
    Join Date
    Jul 2010
    Location
    Fort Wayne
    Posts
    20

    Re: Hesitation/Runs Rough when warm and only a cruise speed

    Thanks. Do you think this is at all related to why it is idling so high? Or would you suspect another issue?

    Quote Originally Posted by NEUMANNZZ View Post
    replace the egr valve with an oem. not autozone crap.

  10. #10
    GMC RULZZ NEUMANNZZ's Avatar
    Join Date
    Mar 2005
    Location
    San Diego
    Age
    47
    Posts
    20,242

    Re: Hesitation/Runs Rough when warm and only a cruise speed

    yes it could be related to high idle vacuum leak.
    Last edited by NEUMANNZZ; 11-12-2010 at 04:32 PM.
    O2 GMC RCSB 4.8L V8 AUTO 3.73's
    rebuilt/beefed up 4L60E(at 43,000miles)
    Matching Ninja 500r


 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •