***Login to the Forum here ***

Support FSC and see no ads! - Click Here
Results 1 to 3 of 3

bad fuel pump? Pressure regulator? 2001 5.3L

This is a discussion on bad fuel pump? Pressure regulator? 2001 5.3L within the Technical / Maintenance forums, part of the General Discussion category; Fuel pressure test results, 2001 suburban 5.3L: key on (cycled 3 times or so) 45 psi engine on and running ...

  1. #1
    Registered User
    Join Date
    Jun 2010
    Location
    South Dakota
    Posts
    18

    bad fuel pump? Pressure regulator? 2001 5.3L


    Support FSC and see no ads! - Click Here
    Fuel pressure test results, 2001 suburban 5.3L:

    key on (cycled 3 times or so) 45 psi
    engine on and running (idle) 50 psi
    idling, with Vac. line on Fuel Pressure Regulator pulled : 58 psi

    engine shut down: 45 psi
    after ten minutes: 38-39 psi

    This morning, at about -5 degrees F, I needed to cycle the key about 7 times before it would start.

    I replaced the fuel pump with an "Airtex" about 1.5 months ago. I did not check the pressures at that time.

    There was no fuel dripping from the vac line on the FPR.


    I did replace the fuel filter at the time of the pump replacement, FWIW.



    Bad FPR? I guess the way to check is to somehow block off the return hose and watch the fuel pressure, correct?

    Bad Fuel Pump? I hate to consider this, but it is possible. Last time, it was about 10 hrs of my time. This time, maybe 4-6 hrs, but I hate to do that again.

    Thanks in advance,

  2. #2
    Registered User Tweaks's Avatar
    Join Date
    Sep 2007
    Location
    Cape Cod, MA
    Age
    33
    Posts
    3,921

    Re: bad fuel pump? Pressure regulator? 2001 5.3L

    Hate to say it, but I'd suspect the fuel pump.

    A bad FPR typically causes a prolonged start, but it does eventually start. Once it does start, it sputters for a few seconds while the signature cloud of rich mixture smoke exits the tailpipe. This doesn't sound like what you have going on.
    00 RCSB Z71/JBA cat-back/Z71 Tahoe valance/EBC slotted&drilled rotors with SS lines & SS braided hoses/Edelbrock headers/BB tune/6000k HID low beam & fog lamps/Auto-headlight disable mod(nice)/Vette servo/LT1 E-fans/LED gauge cluster/Titan 18" wheels/Rollpan/Belltech rear sway bar/2-4 drop

  3. #3
    Registered User
    Join Date
    Nov 2010
    Location
    Calgary
    Posts
    3

    Re: bad fuel pump? Pressure regulator? 2001 5.3L

    Right before my fuel pump went, for about a month before when it got really cold, it would start fine, then chug out. I would have to stay outside until it warmed up a bit with my foot on the accelerator. The check engine light that came on for me was P0172,and P0174 (engine to lean bank 1 and 2) Also it kept saying random multiple misfire. Then it just started chugging out while driving and the fuel pump was shot. Try some fuel line anti-freeze maybe. I didn't have the idea to check the fuel line pressure. If you just replaced the pump you should be able to get warranty on it?

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •