GM Inside - Ford Inside - Ford Ranger - Jeep - American Muscle

Support FSC and see no ads! - Click Here
Results 1 to 15 of 15
Like Tree1Likes
  • 1 Post By para driver

HEY ALL! OIL PUMP 97 chevy truck fullsize

This is a discussion on HEY ALL! OIL PUMP 97 chevy truck fullsize within the Technical / Maintenance forums, part of the General Discussion category; Do you need to lift the engine up to replace a oil pump on a 97 chevy silverado z71. Is ...

  1. #1
    Registered User
    Join Date
    Sep 2009
    Location
    Burnsville
    Posts
    23

    HEY ALL! OIL PUMP 97 chevy truck fullsize


    Support FSC and see no ads! - Click Here
    Do you need to lift the engine up to replace a oil pump on a 97 chevy silverado z71.
    Is there any alternative ? Thanks.

  2. #2
    Stuck in Ohio. NeverFastEnough's Avatar
    Join Date
    Aug 2010
    Location
    Wisconsin
    Age
    21
    Posts
    41

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    You might be able to do it with the motor in the truck but it's going to be a pain in the a$$ I bet (and just because you might be able to do it, doesn't always mean you should) lol. I think I'd just pull it and check everything out instead of just the pump if the pump went out you know? Plus it's way nicer working on something on the stand.
    Last edited by NeverFastEnough; 09-09-2011 at 04:32 PM.

  3. #3
    Registered User
    Join Date
    Feb 2010
    Location
    SW OH
    Posts
    1,941

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    In that motor, the oil pump basically NEVER goes bad.

    What's the real problem? Better to start with that, than jump directly to something time-consuming and futile.

  4. #4
    Registered User
    Join Date
    Mar 2011
    Location
    Pensacola, FL
    Posts
    230

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    DONT PULL THE MOTOR, the oil pump plastic collars are notorious for cracking and breaking .....pull the passenger side 2 bolts holding the front axle tube up, unbolt the exhaust and remove it, take the dust cover off of the transmission , and whatever else is in the way....pry down on the mounting flange and once you unbolt the pan it will pretty much hit you in the head falling out probably missed a thing or two but once you get under there you will see what needs to come off...good luck I did mine in 2 hrs taking my time and using air tools...put a high volume pump back in it and the steel drive shaft for it DO NOT USE THE PLASTIC ONES LIKE THE FACTORY IT WILL BREAK....and add an extra half quart of oil
    Last edited by Big Red 1500; 09-09-2011 at 04:48 PM.




    1997 RCSB Z71 5.7 Vortec, 411 PCM , Ultra gauge, SS Headers, EGR Delete, Magnaflow Hi-flow cat assembly, Cat back with flowmaster 40, Transbuilderguy Built 4l60E, Yukon Duragrip Posi 3.73, 33 x 12.5 Maxxis Big Horn

  5. #5
    Stuck in Ohio. NeverFastEnough's Avatar
    Join Date
    Aug 2010
    Location
    Wisconsin
    Age
    21
    Posts
    41

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    That they are, but if your pump went out I think I'd go in and look everything over just because. Just my 2 cents, take it for what it's worth.

  6. #6
    Registered User
    Join Date
    Sep 2009
    Location
    Burnsville
    Posts
    23

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    Im pretty sure it's the pump I've had this ole girl since she was new. Done all the repairs myself, I'm a heavy machine
    Operator/mechanic. The pressure was up and down a couple weeks ago and has now is at 0 all the time except for a cold start she'll push 50psi then drop to zero immediately. When it's warmed up from a start it's pushin 1 psi haha.
    From a cold start when there good oil pressure for the few moments I have it the motor purrs drops than it ticks a bit not much just a bit. Deffinitly not a bearing I would hear that and deffinitly not the sensor I wouldn't hear a tick when the pressure dropped. I also just replaced the distributor gear and stoped the sluggish issue. But since the oil issue the sluggish is back and leads me to think the gear witch is on the oil pu
    P that aligns with the distributor witch the cam runs both is worn. Oil pump side that is.

  7. #7
    Registered User
    Join Date
    Feb 2010
    Location
    SW OH
    Posts
    1,941

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    Nothing wrong with the pump.

    If it ACTUALLY had ZERO oil pressure, it would have blown up A LONG TIME AGO.

    Believe that the motor still works. Disbelieve the gauge.

    Sounds to me like it needs an oil pressure sending unit.

  8. #8
    Registered User para driver's Avatar
    Join Date
    May 2009
    Location
    Dallas
    Posts
    564

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    when sending units fail, they go HIGH..
    NeverFastEnough likes this.
    '95 Tahoe LT 4x4, TBI with Vortec crate motor.
    God created all men, and Sam Colt made them equal.

  9. #9
    Stuck in Ohio. NeverFastEnough's Avatar
    Join Date
    Aug 2010
    Location
    Wisconsin
    Age
    21
    Posts
    41

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    One of the motors we had did that. It had a spun bearing or two.
    I would tear that motor out and down.

    I'd also like to take this time to age with para driver.
    Last edited by NeverFastEnough; 09-09-2011 at 09:40 PM.

  10. #10
    Registered User
    Join Date
    Feb 2010
    Location
    SW OH
    Posts
    1,941

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    Sending units can fail by reading wrong either way; or by leaking. If one leaks it's almost always electrically fornicated as well.

    It's CHEEEEEEEEP and EEEEEEEEEEEZIE to replace. Try it first.

  11. #11
    Registered User
    Join Date
    Sep 2009
    Location
    Burnsville
    Posts
    23

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    I will try the sending unit this morning I know where it is it's a 5 min fix hope it works I just don't think it's that.

  12. #12
    Stuck in Ohio. NeverFastEnough's Avatar
    Join Date
    Aug 2010
    Location
    Wisconsin
    Age
    21
    Posts
    41

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    Good luck hopefully that works.

  13. #13
    Registered User dave89iroc's Avatar
    Join Date
    Sep 2007
    Location
    SE Michigan
    Age
    36
    Posts
    4,815

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    Quote Originally Posted by para driver View Post
    when sending units fail, they go HIGH..
    nope, most I see fail and read low
    ASE Master Certified Technician

    2000 Silverado 6.0 4L80E 2wd
    *RIP*1994 Z71 SCLB 355, Dart Heads, 10.5:1 CR, PM rods, CC XR270HR

  14. #14
    Registered User
    Join Date
    Sep 2009
    Location
    Burnsville
    Posts
    23

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    Well I should have saved the 20 bucks but no biggie the sending unit is installed and just as I expected no fix. But now it reads differently from before before it wouldnt read over 1 while now it shoots up and down from 40 to 0 then drops to 0 at idel. Very strange maybe it's a gauge. Next I will put a mechanical gauge directly on the engine. Where is that installed?

  15. #15
    Registered User
    Join Date
    Feb 2010
    Location
    SW OH
    Posts
    1,941

    Re: HEY ALL! OIL PUMP 97 chevy truck fullsize

    Same place the sending unit goes

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •