***Login to the Forum here ***

Support FSC and see no ads! - Click Here
Results 1 to 11 of 11

98 5.7L Vortec Won't Start!

This is a discussion on 98 5.7L Vortec Won't Start! within the Technical / Maintenance forums, part of the General Discussion category; Hello All- So I have to say thank you for all of you who have posted so far, these forums ...

  1. #1
    Registered User
    Join Date
    Jan 2012
    Location
    United States
    Posts
    22

    98 5.7L Vortec Won't Start!


    Support FSC and see no ads! - Click Here
    Hello All-
    So I have to say thank you for all of you who have posted so far, these forums are very helpful.
    I am having a very similar issue, and could use some more help.
    I recently purchases a 98 5.7L K1500 that started fine when I first picked it up and has had issues ever since. It will crank and crank, almost fire, sputter, but not fire. I started by trying the basics, cam and crankshaft sensors, timed it, and replaced the fuel filter. Nothing worked, until I got it into the garage and heated it up and it started right up. I had heard great things on the MFI conversion, and decided I would try that first, even knowing my fuel pressure was a little low, 52-57psi, because the new Delphi Fuel Pump was only about a year old and I thought the new MFI system might not need as much pressure as the stock SCPI. Did the conversion, and the thing started great for a couple days, then back to the same crank and crank with no fire. So I dumped a can of HEET in just to see what happened, and she roared on barely touching the key. At this point I though maybe bad gas, but it didn't start a couple days later, so then I thought maybe it was the extra octane that compensated for low fuel pressure. So i replaced the fuel pump, and it started for 2 days, and now I am back to no start! I don't really want to just THROW parts at it, but if this is all I have left, then maybe I will.
    So here are my thoughts on the last of the possibilities. Please let me know where you would start.
    1) Weak Coil
    2) Bad Rotor
    3) Bad Cap
    4)Throttle Position Sensor
    5)Temp Control Sensor...CTS right?
    6) IAT sensor
    7)Compression

    Once it starts, it runs great, but it is cold here now and every time it doesn't start, I scramble to get another ride etc to work, and want to know what fixed it when I fix it. Also, I do have spark when it won't start, the "quality" i guess I am not that confident on.

    Please, any thoughts would be great on trying to narrow it down as all these parts would be a couple hundred. Also, haven't looked at the compression yet, but does anyone else think that makes sense. A guy at chevy suggested I check that, but I have never read anything about that in all the forums I have been looking at lately. His theory was if I have bad compression, it means that the rings aren't sealing and the gas is just flowing around. This doesn't quite add up to me based on that when it starts it runs so well and I get no codes, but maybe I am wrong here.

    Thanks!

  2. #2
    Registered User
    Join Date
    Nov 2011
    Location
    Southeastern Michigan
    Age
    43
    Posts
    607

    Re: 98 5.7L Vortec Won't Start!

    Fuel pressure seems low.. but since you say it starts when its harm and not when its cold , I would replace the CTS for sure then go from there..My 96 wont run at all with Fuel presure below 55-56psi .. so that may be another area to revisit if the CTS doesnt fix the issue...Any codes in it? if so what are they?

  3. #3
    Registered User
    Join Date
    Jan 2012
    Location
    United States
    Posts
    22

    Re: 98 5.7L Vortec Won't Start!

    I am sorry, I should clarify, the fuel pressure WAS 52-57psi before i decided to replace it. Now is it 60psi and above with new fuel pump.
    And I actually think I meant ECT not CTS...I am not sure that exists. If I am remembering right, there is a Engine Coolant Temp sensor and a Intake Air Temp sensor.
    96Z71Siverado: Is the ECT considered the Temperature Sensor some people suggest replacing or is there indeed a CTS that is yet another sensor?
    Thanks!
    Also, I did replace the Crank Shaft Sensor but didn't do the relearn procedure, but I don't think this would sometimes allow it to start and sometimes not. I think a Dist. Cap might be where I start tonight, but if that doesn't solve it, what next? The only code I have seen is P0300 which is a random misfire, but the tech2 said it was very minimal and the CEL isn't lit. Thanks!

  4. #4
    I am sinner JWolfe75's Avatar
    Join Date
    Nov 2004
    Location
    NJ
    Age
    39
    Posts
    2,947

    Re: 98 5.7L Vortec Won't Start!

    Do you have a tech2?

    If so, do the relearn, it takes minutes and free....
    '05 GMC 2500 HD LLY
    '07 TBSS AWD 3SS
    Quote Originally Posted by BHB View Post
    Ummm...By that, I think that would require sticking my own finger into my "Doug".

  5. #5
    Registered User
    Join Date
    Nov 2011
    Location
    Southeastern Michigan
    Age
    43
    Posts
    607

    Re: 98 5.7L Vortec Won't Start!

    CTS= Coolant temp sensor..it tells the ECM how cold it is and regulates fuel in this manner.. your problem based on what you said seems to be temperature sensitive..So that where I would start..check sevice manual for location as it has slipped my mind..
    The ECT is the sensor dor the temp gauge.. probably in the side of thr head, shouldnt have any affect on the vehicle not starting.
    If you have spark you do not have an ignition problem ! Are the plugs wet with fuel? try replacing them too once you've replaced the CTS
    Will it start and run if you hold the throttle off of idle?

  6. #6
    Registered User
    Join Date
    Jan 2012
    Location
    United States
    Posts
    22

    Re: 98 5.7L Vortec Won't Start!

    I do have access to one, but don't have one. I will see if I can get a hold of it and do it soon, but it doesn't seem to add up as it starts after being in the garage a bit, and then does so for another day or so. But i will definitely give it a shot. Thanks!

  7. #7
    Registered User
    Join Date
    Jan 2012
    Location
    United States
    Posts
    22

    Re: 98 5.7L Vortec Won't Start!

    I will try a CTS then and see how that goes. It will not start with the throttle off of idle, and have waited on replacing plugs as I have been trying to narrow the problem down, but maybe that is a good place to start too. Thanks!

  8. #8
    Registered User
    Join Date
    Nov 2011
    Location
    Southeastern Michigan
    Age
    43
    Posts
    607

    Re: 98 5.7L Vortec Won't Start!

    I dont understand this whole Crank sensor (Re-learn) process..I replaced the crank sensor in my truck years ago, just swapped it.. no other proccess involved , runs great..its just a hall affect switch in a sence...Hmmmmm this one keeps puzzling me..

  9. #9
    loose nut behind da wheel JeremyB's Avatar
    Join Date
    Jun 2002
    Location
    Wisconsin
    Posts
    1,498

    Re: 98 5.7L Vortec Won't Start!

    Replace cap and rotor, there is probably a crack internal to the cap and it may be crossfiring. I end up replacing my cap and rotor every other year for starting issues, might be related to the winters and summers we have in the northern states

  10. #10
    Registered User
    Join Date
    Jan 2012
    Location
    United States
    Posts
    22

    Re: 98 5.7L Vortec Won't Start!

    I have been keeping this thread alive here...
    http://www.fullsizechevy.com/forum/g...ml#post5521873
    for anyone interested in following it still...
    Thanks for all the input thus far!

  11. #11
    Registered User
    Join Date
    Feb 2012
    Location
    memphis
    Posts
    1

    Re: 98 5.7L Vortec Won't Start!

    i just bought a crank sensor for my 350 and the hayes manual and the little paper that comes with the part says that if you dont do the relearn it will throw a code a might affect how it runs. try having the relearn done before getting other parts

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •