GM Inside - Muscle Cars - Jeep

Support FSC and see no ads! - Click Here
Results 1 to 3 of 3

1999 Silverado- Security. No power to fuel pump or through the relay

This is a discussion on 1999 Silverado- Security. No power to fuel pump or through the relay within the Technical / Maintenance forums, part of the General Discussion category; I have a 1999 chevy 1500 (and a 2001 tahoe). The truck hasn't been starting, so I went to pull ...

  1. #1
    Registered User
    Join Date
    Jan 2012
    Location
    Texas
    Posts
    10

    Lightbulb 1999 Silverado- Security. No power to fuel pump or through the relay


    Support FSC and see no ads! - Click Here
    I have a 1999 chevy 1500 (and a 2001 tahoe). The truck hasn't been starting, so I went to pull the fuel pump because the whine was missing. While it was down I decided to check the power at the harness where it clips into the pump. Nothing (with wife turning the key).

    Decided to check the relay. In the top right (of the four slots at the fuel pump relay) I have power...nowhere else. I had my wife turn the key...nothing. Did the same at the tahoe with the relay protruding enough to touch the prong with the test light and it was the same, except that when she turned the key I would get power at the bottom right and the bottom left. Tried this on the truck and this did not occur.

    Later tested the pulled fuel pump and when directly powered it spun.

    Also, after reading some threads I noticed to check the gauge and sure enough the "security" light flashes when in the "on" position.

    Note, the motor turns over.

    Bad VCD?
    Passlock/Resistance Issue?

    Most items I've read indicate that the truck fired for a moment then shut down. I'm not experiencing this.
    Also tried the 10 minute (did it 30 minutes) key in the "on" position to cycle security but it was still flashing.

    Had an aftermarket alarm. I disconnected the harness from the alarm, and think that is enough the remove that from the possibilities, as my understanding is that it disabled the starter anyway.

    HELP!!!!!!!!!!!!!!

  2. #2
    Registered User
    Join Date
    Jan 2012
    Location
    Texas
    Posts
    10

    Re: 1999 Silverado- Security. No power to fuel pump or through the relay

    Update. I had the battery disconnected from last night. I was careful to reconnect tonight and my security light went away. So I eliminated that possibility and moved to the next...the ignition switch. I pulled apart the column and looked around, but found no corrosion. Still not getting power to the fuel pump relay. Got in bed to continue google searching and came across someone who had a bad ecm b 20amp fuse in the underhood area. Checked mine and it looked ok. Started checking all fuses that surround the fuel pump relay and many more. Found 2 bad fuses. CHanged them and VIOLA!!!!
    Hope it could be as easy for some of you also experiencing this issue.

  3. #3
    Registered User
    Join Date
    Nov 2007
    Location
    Oklahoma
    Posts
    17

    Re: 1999 Silverado- Security. No power to fuel pump or through the relay

    Sounds like a bad PCM (which is your passlock). Good luck may have to bypass it

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •