GM Inside - Ford Inside - Ford Ranger - Jeep - American Muscle

Support FSC and see no ads! - Click Here
Page 1 of 2 12 LastLast
Results 1 to 20 of 25

97 vortec k1500 no spark, please help

This is a discussion on 97 vortec k1500 no spark, please help within the Technical / Maintenance forums, part of the General Discussion category; 97 chevy k1500 silverado 4x4 vortec 220,000 miles with 4l60e. drove it home last night and parked it. went to ...

  1. #1
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    97 vortec k1500 no spark, please help


    Support FSC and see no ads! - Click Here
    97 chevy k1500 silverado 4x4 vortec 220,000 miles with 4l60e. drove it home last night and parked it. went to start it today around 10 am and it just turned over and would not start. pulled off number one plug wire and i have no spark. it has been sleeting and raining for about two days and i thought maybe moisture was the issue until i noticed i had no spark.

    why would it run good and i shut it off one night and then have no spark the next day?

    i also want to add that this has happened to me before. and the truck sat for about a week in my shop and i was stumped so i started to tear it down to the timing chain and for the hell of it i tried to crank it over with the front half tore down and it started to pop over. put it back together without replacing anything and i got it to run but it ran rough then i got it to smooth out. since then i have ran premium fuel in it and seem to have less problems with it.

    i also have had a few times where it would have a bad miss fire then after a while of driving it would run normal. well now it has no spark and im puzzled once again.

    i have looked around other threads and i was thinking about doing the timing chain assembly and checking the timing gear on the distributor considering the mileage. what do you guys think?

    i also want to add that i do have a OBDII actron cp9185 scanner and i ran it a week or so ago and i had a multiple cyl misfire and i had o2 senser codes. i have had two bad o2 sensors for a long time now and it always ran good with no issues. that would not be why i have no spark now. any way i can use my scanner to check the ignition system to see if maybe a coil took a crap or to see if my timing is retarded or jumped by turning it over with the scanner hooked up? i have not been able to check out the scanner to much to see how it all works.

    thanks in advance guys i really need your help or imput. my wife n i have a 5 month old baby girl and times are tough and i cant afford to have our only vehicle down.

  2. #2
    Registered User
    Join Date
    Aug 2009
    Location
    Texas
    Posts
    302

    Re: 97 vortec k1500 no spark, please help

    I'd start moving back up the line on the ignition system. Next would be coil to cap for fire. If it jumped time, it should still fire just not at the correct time.

  3. #3
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    Re: 97 vortec k1500 no spark, please help

    Quote Originally Posted by 96K2500 View Post
    I'd start moving back up the line on the ignition system. Next would be coil to cap for fire. If it jumped time, it should still fire just not at the correct time.
    true, either that or the gear got striped in the distributor. i will check the ignition coil tomorrow for spark directly. if i have spark then i will check out the cap n rotor next. if i still do not have spark, does anyone have a diagram of the ignition circuit?

  4. #4
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    Re: 97 vortec k1500 no spark, please help

    the truck turns over really hard, and you can feel the whole truck shake when it turns over. i wonder if my timing chain broke.

  5. #5
    Registered User young blood's Avatar
    Join Date
    Oct 2007
    Location
    burleson
    Age
    23
    Posts
    723

    Re: 97 vortec k1500 no spark, please help

    well adressing the first problem of no spark i have a 97 k1500 as well and i just recently had this same issue. it was the hall effect sensor in the dizzy when it rained it would take a long time to start or not start at all then got to the point where it would not start at all and i had no fire. now if u unplug the connector from the coil there are three wires going to it one is ground one is constinte 12 volts and one is a pulser coming from the ecm which picks up voltage from the hall effect sensor in the dizzy if u dont have a pulsing 12 volts on that wire then ur dizzy needs to be replaced as im pretty sure u cant buy that sensor
    If you aint getting stuck or breaking something you aint really offroading
    NOS is like a hot chick with STD\'s, You know you wanna hit it, but are afraid of the consequences.

  6. #6
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    Re: 97 vortec k1500 no spark, please help

    yeah it only happens once in a great while. but when it happens it wont start until a few days or a week later. or it would do it when i was driving in the slush it would cut in and out or like a few times a year when it was raining out. as long as i kept driving and accelerating i could keep it running and after a while it would stop doing it. never did get down to the bottom if it since i didnt know where to start. when i ran the scanner i got a multiple cyl misfire code but i didnt know if my scanner would tell me which cyl. wernt firing.

  7. #7
    Registered User young blood's Avatar
    Join Date
    Oct 2007
    Location
    burleson
    Age
    23
    Posts
    723

    Re: 97 vortec k1500 no spark, please help

    well dizzy problems will cause multiple misfires when u loose spark again check that and it will let u know whats going on the hall effect sensor itself wont throw a code other then random misfier and when it goes out completly and wont start there wont be a code
    If you aint getting stuck or breaking something you aint really offroading
    NOS is like a hot chick with STD\'s, You know you wanna hit it, but are afraid of the consequences.

  8. #8
    You Fartknocker!!!!! TribalVision's Avatar
    Join Date
    Jul 2001
    Location
    A, A
    Age
    45
    Posts
    4,925

    Re: 97 vortec k1500 no spark, please help

    The crab style Distributor caps are prone to failures on the vortecs. But with those issues it really doesnt crank hard or rough. It cranks over easy without any hint of starting. but they fail just as yours usually during damp weather and a no start.
    Tribalvision has Risen!!!! Those who have heard it Know!!

    Click It Dammit!!!!


  9. #9
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    Re: 97 vortec k1500 no spark, please help

    i mean it turns over but kind of rough. think the battery is getting low.

  10. #10
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    Re: 97 vortec k1500 no spark, please help

    ok so like a few days later i decided to put the battery back in it and try to start it and it started rite up. now why is it doing this? dont run for a few days and then now it runs and i have spark back and i didnt even do a thing to it. it must be a moisture problem somewhere but i have no idea where to start on seeing where moisture is affecting it. any ideas on what i can try.

  11. #11
    Registered User
    Join Date
    Feb 2011
    Location
    central wi
    Posts
    87

    Re: 97 vortec k1500 no spark, please help

    id start with cap rotor and plug wires and some die electric grease

  12. #12
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    Re: 97 vortec k1500 no spark, please help

    Quote Originally Posted by c&k1500 View Post
    id start with cap rotor and plug wires and some die electric grease
    already replaced those parts.

  13. #13
    Registered User blackchevyguy's Avatar
    Join Date
    May 2009
    Location
    texas
    Posts
    481

    Re: 97 vortec k1500 no spark, please help

    what the hell i got the same problem,got power after coil.i replaced my cap and rotor and still nothing.

    i wasnt born in texas,but i got here as fast as i could.
    96-SAS,D44,37s,4:56,no front drive shaft yet..

  14. #14
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    Re: 97 vortec k1500 no spark, please help

    pop the cap off and turn it over and see if the dist. is turning when you turn it over. if it is not then your gear at the bottom of the distributor is striped out.

  15. #15
    Registered User blackchevyguy's Avatar
    Join Date
    May 2009
    Location
    texas
    Posts
    481

    Re: 97 vortec k1500 no spark, please help

    Quote Originally Posted by idriveafastcar View Post
    pop the cap off and turn it over and see if the dist. is turning when you turn it over. if it is not then your gear at the bottom of the distributor is striped out.
    It's turning fine..

    i wasnt born in texas,but i got here as fast as i could.
    96-SAS,D44,37s,4:56,no front drive shaft yet..

  16. #16
    The Mustang Man
    Join Date
    Jul 2011
    Location
    Jawja
    Posts
    458

    Re: 97 vortec k1500 no spark, please help

    probably the ICM

  17. #17
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    Re: 97 vortec k1500 no spark, please help

    did you pull number one plug wire and see if you get spark out of it? if you have spark at number one maybe its a fuel issue. if you have fuel and spark then it could be a timing issue.

  18. #18
    Registered User blackchevyguy's Avatar
    Join Date
    May 2009
    Location
    texas
    Posts
    481

    Re: 97 vortec k1500 no spark, please help

    yea i pulled it out no spark.an gas is not a problem theres plenty of preasure pushing it. how can i test the icm?

    i wasnt born in texas,but i got here as fast as i could.
    96-SAS,D44,37s,4:56,no front drive shaft yet..

  19. #19
    Registered User idriveafastcar's Avatar
    Join Date
    Jan 2012
    Location
    Central Wisconsin
    Posts
    105

    Re: 97 vortec k1500 no spark, please help

    if you have spark from the coil and no spark out of the cap to the end of the plug wire than id replace the cap and rotor. ir if you replaced that clean the contacts good. this time of year where im at we have a lot of moisture and it got me twice this year going from 32 deg to 75 in the same day. everything was condensating in my cap. i had to remove and dry it out before i could get it to fire again.

  20. #20
    Registered User blackchevyguy's Avatar
    Join Date
    May 2009
    Location
    texas
    Posts
    481

    Re: 97 vortec k1500 no spark, please help

    there good bec there only two days old.and ijust replaced my pick up coil and ignition coil and still nothing. im guessin now the crank sensor is next. but what if it dont start after that?

    i wasnt born in texas,but i got here as fast as i could.
    96-SAS,D44,37s,4:56,no front drive shaft yet..

 

 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •