***Login to the Forum here ***

Support FSC and see no ads! - Click Here
Results 1 to 17 of 17

2002 Silverado Z71 - 4x4 not working

This is a discussion on 2002 Silverado Z71 - 4x4 not working within the Technical / Maintenance forums, part of the General Discussion category; I have a 2002 Silverado and the 4x4 isn’t working. I push the button and the 4x4 switch blinks for ...

  1. #1
    Registered User
    Join Date
    Sep 2012
    Location
    United States
    Posts
    9

    2002 Silverado Z71 - 4x4 not working


    Support FSC and see no ads! - Click Here
    I have a 2002 Silverado and the 4x4 isn’t working. I push the button and the 4x4 switch blinks for a few second and you can hear/feel the actuator click in below.....just like normal. Then it lights up in the proper 4x4 mode just like it should. All indications appear that it’s working… but it’s not.

    No "service 4x4 codes" or anything. Another thing… I turned the front drive shaft by hand… spins freely in 2hi like it should. Switched to 4L and the driveshaft locks down like it should. Again… everything seems to be working… just isn’t. I didn’t find out until yesterday when I got stuck… and couldn’t ever get the front tires to spin.


    What should I check? Also the ABS light is on in the truck…has been for a while. I read someone that this can cause the 4x4 not to lock in ??

  2. #2
    Registered User
    Join Date
    Nov 2011
    Location
    Oklahoma
    Posts
    73

    Re: 2002 Silverado Z71 - 4x4 not working

    Quote Originally Posted by 2002_Silverado View Post
    I have a 2002 Silverado and the 4x4 isn’t working. I push the button and the 4x4 switch blinks for a few second and you can hear/feel the actuator click in below.....just like normal. Then it lights up in the proper 4x4 mode just like it should. All indications appear that it’s working… but it’s not.

    No "service 4x4 codes" or anything. Another thing… I turned the front drive shaft by hand… spins freely in 2hi like it should. Switched to 4L and the driveshaft locks down like it should. Again… everything seems to be working… just isn’t. I didn’t find out until yesterday when I got stuck… and couldn’t ever get the front tires to spin.


    What should I check? Also the ABS light is on in the truck…has been for a while. I read someone that this can cause the 4x4 not to lock in ??


    ABS and Brake light on? I bet thats your problem...I got both lights on but my 4x4 still works, thank god.

    Use the search function, I remember there were some threads about this a week or so ago.



    Good luck!

  3. #3
    Registered User
    Join Date
    Sep 2012
    Location
    United States
    Posts
    9

    Re: 2002 Silverado Z71 - 4x4 not working

    Just the ABS light is on.... it has been on for a few years... but I havent tried to use the 4 wheel drive since the other day when I got stuck.

    Quote Originally Posted by McNorris View Post
    ABS and Brake light on? I bet thats your problem...I got both lights on but my 4x4 still works, thank god.

    Use the search function, I remember there were some threads about this a week or so ago.



    Good luck!

  4. #4
    Registered User
    Join Date
    Sep 2012
    Location
    United States
    Posts
    9

    Re: 2002 Silverado Z71 - 4x4 not working

    ok.. if this is any help...I jacked up one front tire….. hit the 4hi button…. Then turned the tire by hand.... the front drive shaft would turn like normal. Same thing with 4 L….

    So my actuator is ok? I can hear the motor working under there…

  5. #5
    Resident Dick Quyonmob's Avatar
    Join Date
    Nov 2005
    Location
    Lanark, Ontario
    Age
    33
    Posts
    14,678

    Re: 2002 Silverado Z71 - 4x4 not working

    You are feeling the encoder motor shift the trans, not the actuator engaging.

    Pull the actuator from the front diff, plug it back into the harness and see if it extends when shifted to 4wd (KOEO).

  6. #6
    Registered User
    Join Date
    Sep 2012
    Location
    United States
    Posts
    9

    Re: 2002 Silverado Z71 - 4x4 not working

    ""Pull the actuator from the front diff, plug it back into the harness and see if it extends when shifted to 4wd """

    Just pulled it to check.... it's extending back and forth like it should

  7. #7
    Resident Dick Quyonmob's Avatar
    Join Date
    Nov 2005
    Location
    Lanark, Ontario
    Age
    33
    Posts
    14,678

    Re: 2002 Silverado Z71 - 4x4 not working

    Is it Auto-Trac? (Auto 4x4) button? If so, clutches may not hold under a load, or t-case is filled with wrong fluid causing damage.

    Not Auto-trac... I would think internal issue to diff shift mechanism (pass side of diff tube).

    Summary:
    Encoder works (shifts through ranges)
    Actuator works (plunger extends/retracts)
    TCCM works (t-case is remaining in selected gear)
    Panel switch is fine (no random shift or constant blink)
    Last edited by Quyonmob; 09-04-2012 at 12:57 PM.

  8. #8
    Registered User
    Join Date
    Sep 2012
    Location
    United States
    Posts
    9

    Re: 2002 Silverado Z71 - 4x4 not working

    yes, Auto Trac

  9. #9
    Resident Dick Quyonmob's Avatar
    Join Date
    Nov 2005
    Location
    Lanark, Ontario
    Age
    33
    Posts
    14,678

    Re: 2002 Silverado Z71 - 4x4 not working

    Whats the t-case filled with? Service interval is only 50Kmi, and requires Auto-trac II fluid (blue).

    Drain and refill the t-case, and cross your fingers.

  10. #10
    Registered User
    Join Date
    Sep 2012
    Location
    United States
    Posts
    9

    Re: 2002 Silverado Z71 - 4x4 not working

    Yes, I changed the fluid and put the blue fluid in it about 20K miles ago...

  11. #11
    Resident Dick Quyonmob's Avatar
    Join Date
    Nov 2005
    Location
    Lanark, Ontario
    Age
    33
    Posts
    14,678

    Re: 2002 Silverado Z71 - 4x4 not working

    How many miles?

    Was either front tire spinning? (only one will spin when stuck, it's an open diff)

  12. #12
    Registered User
    Join Date
    Sep 2012
    Location
    United States
    Posts
    9

    Re: 2002 Silverado Z71 - 4x4 not working

    150K miles... never got either tire to spin.. even after steering right to left, etc...

  13. #13
    Resident Dick Quyonmob's Avatar
    Join Date
    Nov 2005
    Location
    Lanark, Ontario
    Age
    33
    Posts
    14,678

    Re: 2002 Silverado Z71 - 4x4 not working

    Internal damage to t-case clutches (won't hold under load) or shift mechanism in diff not engaging front axle.

    Now you'll have to get it on jack stands, put it in 4wd and see if the front tires turn, if they do, problem is in the t-case case clutches, if they don't, problem is in the front diff.

  14. #14
    Registered User
    Join Date
    Sep 2012
    Location
    United States
    Posts
    9

    Re: 2002 Silverado Z71 - 4x4 not working

    """Now you'll have to get it on jack stands, put it in 4wd and see if the front tires turn, if they do, problem is in the t-case case clutches, if they don't, problem is in the front diff""""

    front axle is engaging.... I jacked up one tire front tire the other day... but in 4x4 and turned the tire by hand... it was hard to turn.. but the front drive shaft was turning as well when I did this. that axle is locking down as normal when I put in 4x4

    Do you think it's a waste of time to change out the tcase motor and encoder? I can change this, but If the problem is internal in the case... I'm not fixing it.

  15. #15
    Resident Dick Quyonmob's Avatar
    Join Date
    Nov 2005
    Location
    Lanark, Ontario
    Age
    33
    Posts
    14,678

    Re: 2002 Silverado Z71 - 4x4 not working

    Quote Originally Posted by 2002_Silverado View Post
    Do you think it's a waste of time to change out the tcase motor and encoder? I can change this, but If the problem is internal in the case... I'm not fixing it.
    Does the t-case shift to 4lo? If so, yes, it is a waste of time and money. All the encoder does is shift the t-case. From what I am reading the range portion of the t-case is fine, the front output is the issue.

    Still havent determined if the t-case powers the front output in 4hi. Pull the actuator leave it hang, shift to 4hi, see if you can turn the front DS by hand. Actuator has to be removed, as it will also stop the DS from turning in 4hi.
    Last edited by Quyonmob; 09-05-2012 at 01:42 PM.

  16. #16
    Registered User
    Join Date
    Sep 2012
    Location
    United States
    Posts
    9

    Re: 2002 Silverado Z71 - 4x4 not working

    Yes, the case shifts through all cycles like normal... 2H, 4H, and 4L. It also makes all the normal sounds from underneth… and no service 4x4 codes or anything.
    I pulled the actuator from the front axle and it extends in and out like it should.

    When I put in 4x4 I cant turn the front drive shaft. It spins freely like it should in 2H

    Guess I will send back that encoder motor and not install it on the tcase. sounds like a waste of time..
    Last edited by 2002_Silverado; 09-05-2012 at 02:14 PM.

  17. #17
    Resident Dick Quyonmob's Avatar
    Join Date
    Nov 2005
    Location
    Lanark, Ontario
    Age
    33
    Posts
    14,678

    Re: 2002 Silverado Z71 - 4x4 not working

    Quote Originally Posted by 2002_Silverado View Post
    When I put in 4x4 I cant turn the front drive shaft.
    Yes, but...

    Quote Originally Posted by Quyonmob
    Still havent determined if the t-case powers the front output in 4hi. Pull the actuator leave it hang, shift to 4hi, see if you can turn the front DS by hand. Actuator has to be removed, as it will also stop the DS from turning in 4hi.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •