GM Inside - Muscle Cars - Jeep

Support FSC and see no ads! - Click Here
Results 1 to 13 of 13

4L60E transmission issues, help please!

This is a discussion on 4L60E transmission issues, help please! within the Technical / Maintenance forums, part of the General Discussion category; hey im new to the site and i need some help. i recently recieved my corvette servo for my 99 ...

  1. #1
    Registered User
    Join Date
    Jul 2012
    Location
    WA
    Posts
    15

    4L60E transmission issues, help please!


    Support FSC and see no ads! - Click Here
    hey im new to the site and i need some help.

    i recently recieved my corvette servo for my 99 Silverado 1500 NBS. i decided while i was wrenching on the trasmission i might as well replace the filter and fluid. Bad Idea. i got the new servo installed and went to pull the pan and of course it was a pain in the ass and i ended up breaking the connector off the 2-3? shift solenoid i think. i went to the parts store and got a new solenoid installed it put the pan back on and filled to the appropriate level of fluid. warmed the truck up and took er for a spin. there feels like itd not engaging in D, 3 or 2. only in first. im at a loss. any help is appreciated.

  2. #2
    LM7 Outlawz2004's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,979

    Re: 4L60E transmission issues, help please!

    You got it filled enough? Should take about 5 quarts if I remember right for a fluid and filter change. Check the fluid level after it gets up to operating temp.

  3. #3
    Registered User
    Join Date
    Jul 2012
    Location
    WA
    Posts
    15

    Re: 4L60E transmission issues, help please!

    I put about 5 quarts in and took it down the driveway and got a service engine soon light so i came back to the house and checked the fluid, it was low so i added more and it didnt fix the problem unfortunately.

  4. #4
    LM7 Outlawz2004's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,979

    Re: 4L60E transmission issues, help please!

    contact transbuilderguy, he knows all about them. He is currently building me a trans, but I believe he told me he was going to be out of town until around Wed, but he may reply if you send him a message.
    Last edited by Outlawz2004; 01-12-2013 at 10:18 PM.

  5. #5
    Registered User
    Join Date
    Jul 2012
    Location
    WA
    Posts
    15

    Re: 4L60E transmission issues, help please!

    Thanks, ill do that.

  6. #6
    Registered User
    Join Date
    Jul 2012
    Location
    WA
    Posts
    15

    Re: 4L60E transmission issues, help please!

    i just plugged in a diagnostic machine to my truck and got PO758 code. anyone knows what that means?

  7. #7
    Registered User
    Join Date
    Sep 2011
    Location
    Washington
    Posts
    22

    Re: 4L60E transmission issues, help please!

    p0758 is the shift b solenoid.

  8. #8
    Registered User
    Join Date
    Jul 2012
    Location
    WA
    Posts
    15

    Re: 4L60E transmission issues, help please!

    is Shift b the 2-3 or 1-2?

  9. #9
    Registered User
    Join Date
    Sep 2011
    Location
    Washington
    Posts
    22

    Re: 4L60E transmission issues, help please!

    Quote Originally Posted by scarpzimmerman View Post
    is Shift b the 2-3 or 1-2?
    I believe the B solenoid is the 2-3 shift.

  10. #10
    Registered User
    Join Date
    Jul 2012
    Location
    WA
    Posts
    15

    Re: 4L60E transmission issues, help please!

    Im hoping that maybe i just aaccidentally disconnected the solenoid when installing the tranny pan...i guess i get to get covered in tranny fluid and bash my knuckles up some more. wish me luck.

  11. #11
    Registered User
    Join Date
    Nov 2006
    Location
    Texas, Coast
    Age
    53
    Posts
    994

    Re: 4L60E transmission issues, help please!

    When I went to replacing mine the connect lock tab was broken so I placed a small tie wrap so it wouldn't come loose consider that it as well.

  12. #12
    ASE Certified Trans Tech transbuilderguy's Avatar
    Join Date
    May 2010
    Location
    Orlando, Fl
    Age
    38
    Posts
    1,658

    Re: 4L60E transmission issues, help please!

    I wouls say you probably broke the shift solenoid with the trans pan tryig to shimmy it past the exhaust happens alot there are 2 of them at the rear of the valve body they are both the same its the 1-2 and the 2-3 solenoid. if the locking tabs are broken replace the case harness also.

  13. #13
    Registered User
    Join Date
    Jul 2012
    Location
    WA
    Posts
    15

    Re: 4L60E transmission issues, help please!

    Well since I got the code for the shift solenoid I took the pan back off just enough to reach my hand inside and feel the connector ans sure as **** it was disconnected. I plugged it back in threw the pan back up, filled her with fluid and took it for a spin. Shifts like a dream now. Corevette servo is pretty cool upgrade. Luckily I only managed to smash 9 of my knuckles in the entire process but my truck is back on the road. Thanks for the help guys.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •